Frage von OceansLover, 103

Das billigste Angebot heraussuchen, Excel?

Hallo, ich bin ein ziemlicher Excel-Neuling und habe nun ein Problem. Und zwar habe ich eine Tabelle, in der ich zuvor 3 Busse miteinander vergleichen musste, mit Kosten und Kilometern und allem. Nun ist die Frage, bei welcher Kilometeranzahl der dritte Bus am günstigsten ist. Weiß jemand, mit welcher Formel ich dies berechnen könnte?
Danke schonmal im Voraus :)

Antwort
von Gipfelstuermer, 51

So hier nun die Lösung mit Screenshot!

Eine Hilfstspalte = F habe ich angelegt dort werden mittels der Formel
Anschaffungskosten + kosten pro km * Jahreskilometer * Anzahl der Betriebsjahre die Gesamtkosten berechnet

In der Zelle F17 habe ich ganz simpel =Min(F8:F12) das billigste ausgewertet

Und in der Zelle E17 mit der Formel:
=index(A8:A12;vergleich(F17;F8:F12;0))

den passenden Bus ermittelt.

Dabei wird nach dem Preis aus F17 in dem Bereich F8 - F12 geguckt, wenn er dort gefunden wurde, wird entsprechen der passende Wert der gleichen Zeile aus dem Bereich A8 - A12 ausgegeben.

Antwort
von Gipfelstuermer, 35

Naja der hier wohl formeltechnich einfachste Weg wäre wohl.

Du errechnest in einer getrennten Spalte die Gesamtkosten unter Beachtung der Laufzeit, dass kannst du ja über eine Variable (externe Zelle) mit einbeziehen lassen und dann errechnest du den Min Wert über Min(Zellbezug).

ich lade dir später mal ein Beispiel hoch wie ich das meine.

Expertenantwort
von Ninombre, Community-Experte für Excel, 31

Die Frage ist etwas widersprüchlich: Willst Du den Wert aus einer bereits vorhandenen Tabelle ermitteln oder wirklich berechnen?

Wenn es bereits eine Tabelle gibt, die in etwa so aussieht:
Spalte A: Kilometer
B= Bus 1
C=Bus 2
D=Bus 3

Und in den Zeilen jeweils 100km - 10 EUR - 15 EUR - 20 EUR usw.

Dann kannst Du in Spalte E (Hilfsspalte) jeweils zeilenweise ermitteln, welcher Bus am günstigen ist:

=VERGLEICH(MIN(B2:D2);B2:D2;0) . Zurückgeliefert wird die Spalte in der Matrix B:D, die das Minimum enthält.

Vorausgesetzt der Bus 3 ist nur bei einer bestimmten Kilometerzahl am günstigsten, suchst Du eben diesen Eintrag in der Hilfsspalte
=INDEX(A2:E5;VERGLEICH(3;E2:E5;0);1)

Ich habe nur wenige Beispieleinträge gehabt, daher nur A2:E5, kannst Du nach belieben erweitern.

Die beiden Formeln suchen aber nur in einer bereits gefüllten Tabelle nach einem Eintrag. Wenn Du etwas berechnen willst, müsstest Du die Frage noch etwas ergänzen, damit nachvollziehbar ist, wie gerechnet werden muss.

Antwort
von Wechselfreund, 43

Excel hat viele Funktionen, die "drei Busse vergleichen" wohl eher nicht...

Wie sehen die Tabellen aus, welche Zahlenwerte sollen wie verglichen werden???

Keine passende Antwort gefunden?

Fragen Sie die Community