Zahl oder Buchstabenwert gleichzeitig nutzen Excel?

... komplette Frage anzeigen

4 Antworten

Füge zwei zusätzliche Spalten ein. Wenn A deine Eingabespalte ist, dann bestimmst du in Spalte B den zugehörigen Zahlenwert, in C dann die andere Eingabe, in D den in eine Zahl umgewandelten Wert aus C und in E dann die Summe.

Antwort bewerten Vielen Dank für Deine Bewertung

Ich persönlich würde zwei Zusatzspalten einfügen für die Einträge S und L. Dann kannst du über eine WENN-Abfrage prüfen, ob diese Spalten diese Einträge enthalten und davon abhängig die Uhrzeit ausgeben lassen.

Falls du keine Zusatzspalten haben willst, geht es wohl auch so

=WENN(ISTZAHL(B1);B1;20/24)-WENN(ISTZAHL(A1);A1;13/24)

Hierbei ist es egal, welche Buchstaben drinstehen, solange sie in den entsprechenden Spalten stehen. Falls ein Ergebnis nur dann erscheinen soll, wenn beide Zellen ausgefüllt sind, dann:

=WENN(ANZAHL2(A1:B1)=2;
WENN(ISTZAHL(B1);B1;20/24)-WENN(ISTZAHL(A1);A1;13/24);"")

Antwort bewerten Vielen Dank für Deine Bewertung

Du könntest Zwischenspalten einbauen, in denen der Buchstabe in eine Zeit übersetzt wird.

Beispiel: Spalte A ist die eingegebene Von-Zeit. Spalte B ist die berechnete Von-Zeit mit der Formel =WENN(A1="S";ZEITWERT("13:00");A1) Spalte C ist die eingegebene Bis-Zeit, Spalte D ist die berechnete Bis-Zeit mit der Formel =WENN(C1="L";ZEITWERT("20:00");C1) Spalte E ist dann die getätigte Arbeitszeit mit der Formel =D1-B1 und dem Format "Uhrzeit".

Die Spalten B und D kannst du dann ausblenden und hast genau die Übersicht, die du haben wolltest.

Antwort bewerten Vielen Dank für Deine Bewertung

Da bräuchtest du mehrere Fallunterscheidungen mit WENN und ggf. SVERWEIS.

Um herauszufinden, ob Zahl oder Buchstabe: ISTZAHL

Um z. B. 7 Stunden / 07:00 Uhr in DatumZeit umzuwandeln: 7/24

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von PWolff
22.11.2016, 15:36

Für diesen Fall Formel für C1:

=WENN(ISTZAHL(B1);B1;WENN(B1="L";20/24))-WENN(ISTZAHL(A1);A1;WENN(A1="S";13/24))

Wenn jeweils mehrere Buchstaben möglich sind, SVERWEIS oder geschachtelte WENN.

1

Was möchtest Du wissen?