Frage von rh4001, 96

Wie kann ich bei Excel Leerzeilen überspringen und Werte aus einer Tabelle in eine andere Tabelle übertragen?

Ich gehe mit zwei Freunden bald campen und dazu habe ich eine Packliste erstellt, in welche über Google Drive jeder eintragen kann, was er mitbringt. Damit jeder seine Punkte nochmal übersichtlich aufgelistet bekommt, wollte ich unter jeden Namen nochmal die Dinge auflisten, die er mitbringen muss und wieviel wovon.

Bei Max hab ich mal beispielhaft per Hand eingetragen wie das aussehen soll.

Ich glaube dazu brauche ich die Index, Verweis und Vergleich-Funktion, komme aber nicht dahinter wie das letztendlich aussehen soll. Und vor allem, wie ich die Leerzeilen überspringe.

Ich bin dankbar für jede Hilfe.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 24

Teste mal in I2 (und runterkopieren):

{=WENNFEHLER(INDEX($C$1:$C$25;KKLEINSTE(WENN($C$2:$C$25<>"";ZEILE($C$2:$C$25));ZEILE(A1)));"")}

und in J2 (und runterkopieren):

{=WENNFEHLER(INDEX($A$1:$A$25;KKLEINSTE(WENN($C$2:$C$25<>"";ZEILE($C$2:$C$25));ZEILE(A1)));"")}

**ACHTUNG!** Das sind Matrixformeln.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formeln zu einer Matrixformeln

Klappt es?.

Kommentar von rh4001 ,

Funktioniert perfekt. Vielen Dank dafür!!! Hab nur noch die 25 auf 100 erweitert und die Formel für die anderen Spalten angepasst. Und jetzt macht das Ding genau das was ich wollte.

Kommentar von Oubyi ,

Gern geschehen ☼
Freut mich, dass ich helfen konnte.

Kommentar von Oubyi ,

Danke fürs

Expertenantwort
von Ninombre, Community-Experte für Excel, 49

per Formel ist es kompliziert, wobei ich nicht einmal weiß, ob das in googledocs überhaupt geht, Grundentwurf steht hier beschrieben, müsste man aber noch anpassen, weil Du zusätzlich die Anzahl haben willst:
http://www.at-exceltraining.de/index.php/fragen-a-anworten-zu-excel/49-formeln-u...

Ich würde es mit einer Pivottabelle lösen, jeweils eine pro Teilnehmer
Dafür brauchst Du noch eine Überschrift in A1 (Pivot erfordert für jede verwendete Spalte die Überschrift). In Excel würde sie beispielhaft aussehen wie im Bild
Optisch kann / muss man noch etwas feintunen gegenüber den Standardeinstellungen (z.B. macht eine Zeile Gesamtsumme keinen Sinn wenn auch Grammangaben verwendet werden -> Ausblenden unter Pivotoptionen Ergebnissummen). Kann inhaltlich bei googledocs etwas anders aussehen, ich kann es leider nicht direkt ausprobieren.

edit: na prima, beim Ändern kann ich scheinbar kein Bild mehr anfügen. Kommt in einer eigenen Antwort


Kommentar von rh4001 ,

Danke für die Mühe, aber wenn ich das nicht bei Docs verwirklichen kann, erübrigt sich die Tabelle :(

Kommentar von Ninombre ,

Pivottabellen gehen bei docs, ich kann das nur bei der Arbeit wg. Interneteinstellungen nicht aufrufen und konkret ausprobieren.

https://support.google.com/docs/answer/1272900?hl=de

Expertenantwort
von Ninombre, Community-Experte für Excel, 25

so noch das Bild zur ersten Antwort

Über den Berichtsfilter lässt man die Gegenstände weg, für die keine Anzahl eingetragen ist. Das sieht man im Screenshot nicht

Antwort
von ErsterSchnee, 67

Ich würde das mit einer wenn-dann-Funktion machen.

Kommentar von rh4001 ,

Könntest du mir eine Beispielformel geben? Wenn möglich mit Erklärung. Die Wenn-Funktion an sich kenne ich schon.

Kommentar von ErsterSchnee ,

Wenn B2 ungleich 0 (oder meinetwegen auch wenn B2 nicht leer ist), dann I2 gleich C2 UND J2 gleich A2.

Und dann halt fortführen.

Kommentar von DeeDee07 ,

Und wenn B2 leer ist? Der Fragesteller will eine lückenlose Auflistung.

Kommentar von ErsterSchnee ,

Stimmt - DEIN Vorschlag war natürlich viel besser...^^

Antwort
von pommesohnealles, 55

Du könntest anstatt eine 1 einzutragen bei "Wer bringt mit" die Tabelle anders aufbauen.

Zum Beispiel machst du eine Auflistung, was alles da sein muss, und schreibst dann z.B. Jan 1x, Moritz 1x hin.

Kommentar von rh4001 ,

Das Problem ist, wenn es dazu kommt, dass Essen geplant wird: Dann braucht nicht jede Person einzeln Öl oder Milch o.Ä. einzutragen.

Keine passende Antwort gefunden?

Fragen Sie die Community