Frage von tomtom2401, 44

Kombinationen von Zellen in Excel zählen - wie?

Ich hab eine Tabelle in Excel, in dieser Steht in einer Zeile die Art und unterhalb der Name. Nun möchte ich zählen wie oft bestimmte Kombinationen vorkommen. Bsp:

Art1  | Art2  | Art1  | Art2  | Art3
----------------------------------------
Maier | Huber | Maier | Huber| Huber

----------------------------------------
Art1  | Art2  | Art1  | Art2  | Art1
----------------------------------------
Huber | Huber | Maier | Maier | Huber

Nun sollte die Funktion folgendes Ergeben:

##### | Art1 | Art2 | Art3 
Huber |  2   |   3  |  1
Maier |  3   |   1  |  0

Ist dies ohne Skript möglich? wenn ja wie? Die Daten sind in Struktur fix vorgegeben und können nicht geändert werden.

Antwort
von Ortogonn, 44

Deine Tabelle in Zeilen 1, 2, 4, 5 und Spalten A-E

=SUMMENPRODUKT(($A$1:$E$1=B$7)*($A$2:$E$2=$A8)+($A$4:$E$4=B$7)*($A$5:$E$5=$A8))

Dort, wo die 2 für Huber und Art1 steht, diese Formel reinschreiben und nach rechts und unten kopieren

Bereiche entsprechend deiner Bedürfnisse anpassen.

Kommentar von Ortogonn ,

Das läßt sich sicher auch mit ZÄHLENWENN() bzw. ZÄHLENWENNS() lösen, aber das nutz ich kaum da ich SUMMENPRODUKT() für flexibler und auf Dauer einfacher (immer wieder dasselbe ohne umzudenken) halte

Expertenantwort
von Iamiam, Community-Experte für Excel, 15

Formalantwort

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten