Frage von studentstudent, 65

Excel WENN-Formel: Wie erreiche ich es, dass wenn ein Wert unter z. B. 100 fällt, automatisch der Wert 100 erscheint?

Hallo zusammen, 

ich benötige dringend Hilfe.

Ich habe eine Tabelle mit Prämiensätzen erstellt. Eine Zeile berechnet eine Prämie.

Liegt eine Prämie aber unter einem bestimmten Wert, soll Excel automatisch erkennen, dass der Wert zu gering ist und beispielsweise den errechneten Wert von 131,64 durch die gewünschte Summe, z. B. 1150,00 ersetzen.

Leider habe ich kaum Excel-Erfahrung, aber in die Spalte müsste ja zum einen die Formel, die den Wert erst ausrechnet und dann, sofern dieser Wert nicht an den Wert x heran kommt, automatisch den Wert x verwenden und nicht die eigentlich errechnete Summe.

Ich hoffe, ich habe mich verständlich ausgedrückt. Es wäre super, wenn mir jemand helfen könnte!

:-)

Antwort
von matmatmat, 38

Du kannst mit einer IF (im Deutschen excel: WENN) Verknüpfung
schauen ob das Ergebniss hoch genug ist.

Aus =Prämienformel mußt Du machen:

=WENN((Prämienformel)>X;Prämienformel;"X")

Das vergleicht das Ergebnis der Prämienformel mit X (hier mußt Du eine konkrete Zahl einsetzen oder auf eine Zelle verweisen in der der Wert steht!). Wenn Prämienformelergebniss > X dann wird der Wert der Zelle Prämienformel, wenn nicht wird der Wert X.

Expertenantwort
von Ninombre, Community-Experte für Excel, 27

Wenn die Werte in A1:A100 stehen:

=SUMMEWENN(A1:A100;">=1150")+(ZÄHLENWENN(A1:A100;"<1150")*1150)

Ansatz ist: Erst die Werte summieren, die die Bedingung erfüllen, dann die Anzahl ermitteln, die die Bedingung nicht erfüllen und diese Anzahl * den Mindestwert nehmen.

edit: Beim erneuten Lesen der Frage fällt mir auf, dass Du noch gar nicht beim Summieren bist, sondern beim Berechnen einer einzelnen Prämie. Da gilt dann die bereits in anderen Antworten genannte Wenn-Bedingung.

Antwort
von ShitzOvran, 26

Es wäre Hilfreicher, wenn du erklären (oder zeigen) könntest, wie deine Tabelle aufgebaut ist. Sonst kann dir nur sehr oberflächlich geholfen werden.

=Wenn("errechnete Prämie"<"gewünschte Summe";"gewünschte Summe";"errechnete Prämie")

Antwort
von GanMar, 26

Die Formel muß in eine zusätzliche Spalte:

In Spalte A steht die zu prüfende Zahl

In Spalte B steht: =WENN(A1<100;100;A1)

wenn Du den Wert 100 haben möchtest, wenn in A der Wert kleiner als 100 ist.

Antwort
von mrDoctor, 19

Hallo

Wie du dies mit einer WENN Formel lösten kannst, haben meine Vorredner bereits erklärt. So wie ich das verstehe, suchst du eine variable Lösung? Allenfalls kann dir RUNDEN oder AUFRUNDEN weiterhelfen.

Antwort
von Y0DA1, 23

die Formel geht so:   =WENN(A1<100;100;A1)
das heißt: Wenn A1 kleiner 100; dann 100; ansonsten A1

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 17
=MAX(1150;A1)

Keine passende Antwort gefunden?

Fragen Sie die Community