Frage von Geradon, 30

EXCEL: Spalten über mehrere Tabellenblätter zählen?

Hey,

ich möchte über mehrere Tabellenblätter (die Januar, Februar, ... benannt sind) in Zeile A6-Z6 alle "K"s zählen und dies im ersten Tabellenblatt wiedergeben. Habe bis jetzt keine passende Formel gefunden, bitte um Hilfe :)

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 20

ich kenne keine außer der mühsamen

=zählenwenn(Januar!A6:Z6;"k")+zählenwenn(Februar!A6:Z6;"k")....

Sonst halt per Makrofunktion, falls das in Betracht kommt.

Expertenantwort
von DeeDee07, Community-Experte für Excel, 15

Schreib in das Übersichts-Tabellenblatt die Monatsnamen der vorhandenen Tabellenblätter, z.B. in A1:A12 die Monate Januar bis Dezember (geht ja recht schnell durch autovervollständigen)

Dann verwendest du folgende Formel:

{=SUMME(ZÄHLENWENN(INDIREKT("'"&A1:A12&"'!A6:Z6");"k"))}

Das ist eine Matrixformel. Die geschweiften Klammern {} werden NICHT eingegeben, sondern die Formel wird mit Strg+Shift+Enter abgeschlossen. Das erzeugt die {}.

(adaptiert von http://www.excelformeln.de/formeln.html?welcher=234 und erfolgreich getestet. Man kann natürlich auch was aus der weiter unten stehenden Monatsnamenumwandlungsformel basteln, aber die scheint mir noch etwas unübersichtlicher zu sein)

Keine passende Antwort gefunden?

Fragen Sie die Community