Frage von Schakazulo, 72

Bei Excel prozentuale Differenzen anzeigen?

Hallo, ich habe eine Excel liste mit Noten. Ich habe es bereits hinbekommen mir die passende Note zu der erreichten Prozentzahl anzeigen zu lassen. Ist es auch möglich, dass Excel mir die Prozentpunkte anzeigt, die zur nähst höheren Note fehlen? Dazu müsste Excel die erreichte Note anhand der Prozentzahl mit der nähst höheren vergleichen und daraus die differenz bilden.

Antwort
von iMPerFekTioN, 45

Ja richtig!
Warum machst du das dann denn nicht?

Du rechnest dir doch schon alles aus um die Note zu bekommen, dann nimmst du den Wert bspw.. durch einen SVERWEIS und als Suchkriterium deine Note -1 und suchst dir da den Prozentwert und verglichst diese beiden!

z.B. hast du 66,5% erreicht, was z.B. die Note 3 wäre, Note 2 bekommst du ab 80%

In Zelle A1 Steht dein Prozentwert, in A2 steht deine Note.
Die Notentabelle steht in D1:E6

(Spalte D beinhaltet die Noten, Spalte E die % Werte)

=SVERWEIS(A2-1;D1:E6;2;0)-A1

Dann hast du den %-Wert welcher dir Fehlt um auf die nächst bessere Note zu kommen (In diesem Fall dann 13,5%)


Grüße,


iMPerFekTioN

Kommentar von Schakazulo ,

Danke für die schnelle Antwort, nur habe ich die Noten 1,1.3,1.7... vorliegen. Dies führt zu Notenschritten von 0,3 und 0,4. vielleicht stehe ich aber nur grade auf dem schlauch und es funktioniert damit fast analog :)

Kommentar von iMPerFekTioN ,

Die Frage ist nur, wie du deine %Werte errechnest um auf die Note zu kommen.

Du kannst auch bei Dezimalzahlen sagen du willst den nächstgrößeren Wert (auf oder abgerundet) Minus deiner jetzigen Note haben.

Wenn du deine %-Werte schon hast, du jetzt eine Note von 2,4 hast, das liegt dann sagen wir mal spaßeshalber bei 87,6 %, folgende Formel

=SVERWEIS(ABRUNDEN(A2;0)-1;D1.E6;2;0)-A1

So erhältst du (trotz Dezimalzahl) den nächst kleineren Wert und somit die nächst bessere Note :)

Oder hab ich dein Problem falsch verstanden? :o

Kommentar von iMPerFekTioN ,

Ich hab jetzt nochmal was für dich:

in A1 Schreibst du "Prozentwert erreicht"
In A2 Schreibst du "Note"
In A3 Schreibst du "Fehlende % zur besseren Note"

Deine Notenliste trägst du in C1:E100 ein.

Und zwar so, C1 :C100 Prozentwerte (beliebige von 0-100%)
D1:D100 schreibst du die Formel:

=((100-C1*100)*0,05)+1

Die Formel ziehst du dann runter. (Berechnet dir automatisch die Noten)

In E1:E100 schreibst du die gleichen Prozentwerte wie in C1:C100!

---------------------------------------------------------------------------------------

In B1 trägst du einen beliebigen % Wert ein.
In B2 trägst du diese Formel ein:

=((100-B1*100)*0,05)+1

In B3 trägst du die Formel ein:

=SVERWEIS(ABRUNDEN(B2;0)-1;N11:O16;2;0)-B1

Fertig =D


Grüße,


iMPerFekTioN

Expertenantwort
von Ninombre, Community-Experte für Excel, 36

Geht sicherlich, ohne den Aufbau Deiner Tabelle zu kennen, ist eine konkrete Formel aber schwierig.

Nutzt Du eine verschachtelte Wenn-Formel oder Sverweis mit ungefährem Treffer? WENN ist mühsam, sverweis wäre die flexiblere Variante. Voraussetzung, dass es damit klappt: Aufsteigend sortierte Prozentwerte!

Formel zur Ermittlung der Note gem. Prozent
=SVERWEIS(E2;A2:B7;2;WAHR)

oder

=INDEX(A2:B7;VERGLEICH(E2;A2:A7;1);2)

Kommt aufs gleiche raus, Index+Vergleich ist aber vielseitiger, weil man beim Sverweis den Suchbegriff immer in der ersten Spalte haben muss, beim Index/Vergleich ist das egal

Fehlende Prozentpunkte zur höheren Note:

=INDEX(A2:B7;VERGLEICH(E3-1;B2:B7;0);1)-E2

wenn man schon eine 1 hat, dann kommt ein Fehler. Wenn dieser stört, ggf. noch eine wenn-abfrage davor:

=wenn(e3=1;"";INDEX(A2:B7;VERGLEICH(E3-1;B2:B7;0);1)-E2)

Kommentar von iMPerFekTioN ,

Die Formeln gefallen mir DH!

Hmm. was machst du aber wenn die Note in Dezimalzahlen ermittelt wird? Also mit Zwischenschritten? ;x

Da hänge ich bei meiner Antwort auch rum! :p

Kommentar von Ninombre ,

Wenn die Noten keinen festen Abstand haben, muss man den Zeilenwert ermitteln und um eins erhöhen

=INDEX(A2:B7;VERGLEICH(SVERWEIS(E2;A2:B7;2;WAHR);B2:B7;0)+1;1)-E2
Kommentar von Jackie251 ,

an dem Punkt sieht man wieder einen Vorteil von Index Vergleich: das Suchkritirium muss nicht in der Suchzeile liegen.

Kommentar von Ninombre ,

wobei es dann konseqent wäre beides mal index/vergleich zu nehmen, das sieht dann aber ziemlich unübersichtlich aus

Kommentar von Schakazulo ,

[URL=http://www.bilder-upload.eu/show.php?file=0c7e56-1475831072.png][IMG]http://www.bilder-upload.eu/thumb/0c7e56-1475831072.png[/IMG][/URL] [URL=http://www.bilder-upload.eu/show.php?file=d74a03-1475831101.png][IMG]http://www.bilder-upload.eu/thumb/d74a03-1475831101.png[/IMG][/URL]

Danke für die Hilfe Ihr beiden, irgendwie stimmt es noch nicht ganz.

Ich habe mal zwei Bilder meiner Excel Tabellen hochgeladen, eines von meiner Hilftabelle eines von derjenigen in der ich die Werte haben möchte.

Vielleicht hilft das meinen Fehler zu finden.

Beste Grüße Robin
und Danke :)

Kommentar von Ninombre ,

Ich bin von einer anderen Tabelle für Noten <-> Prozentwert ausgegangen, nämlich, dass jede Note nur einmal da steht und der Prozentwert, ab dem diese Note vergeben wird.
Wenn es geht, solltest Du Deine Aufstellung in Tabelle1 entsprechend verkürzen, dass also jede Note nur einmal genannt wird. Wenn die Prozentsätze weiterhin aufsteigend sind, geht der Zugriff mit

=SVERWEIS(F40;Tabelle1!:A2:B102;2;WAHR)

trotzdem. Das wäre die Formel zur Ermittlung der Note in E40

Mit der umgebauten Notentabelle klappt dann auch die Ermittlung der fehlenden Prozentpunkte

Keine passende Antwort gefunden?

Fragen Sie die Community