Frage von i3asti2311,

AHCI Port 0 Device Error, woran liegt es ?

Hallo Leute,

ich habe ein riesengroßes Problem mit meinem PC, seit einigen Tagen bekomm ich beim hochfahren immer die Meldung "AHCI Port 0 Device Error Press F1 to resume". Sowohl die Systemwiederherstellung als auch die Systemreperatur funktionieren nicht. Meine Vermutung war dass es sich um die Grafikkarte handeln könnte, da diese schon weit über 2 Jahre alt war, also tauschte ich diese aus. Nach dem Umbau musste ich aber feststellen, dass ich die oben genannte Fehlermeldung auch weiterhin noch bekomme. Ich habe auch schon mehrere Programme zur Registry Reperatur drüberlaufen lassen (SmartPCFixer, Smart PC, Reg Clean Pro) allerdings habe ich nach dem Systemscanning festgestellt, dass ich zur Reperatur meiner Registry eine kostenpflichte Lizenz kaufen soll, was ich überhaupt nicht einsehe.

Nun zu meinen Fragen kennt jemand von euch ein gutes KOSTENLOSES Registry Reperatur Tool?

Wo könnte die Ursache in meinem PC liegen, könnte eventuell das Motherboard kaputt sein?

Ich bedanke mich schonmal im vorraus für Antworten.

Antwort von Miraculix76,

also ich tippe darauf, das die festplatte kaputt ist, den mit dem AHCI ist normalerweise die Festplatte gemeint

Das Advanced Host Controller Interface (AHCI) ist ein offener Schnittstellen-Standard für Serial-ATA-Controller. Er ermöglicht es, mit diesen Controllern per Software zu kommunizieren.

von daher ist entweder dein festplattendriver flöten gegangen, oder die Festplatte kaputt, wenn der Rechner mit ner Linux Live CD läuft, sich aber nicht installieren lässt, kannst du davon ausgehn, das die Festplatte kaputt ist

mfg

Kommentar von Miraculix76,

mit dem Trinity Rescue Kit kannst du die Registry direkt bearbeiten, dazu solltest dich aber nen bisl damit auskennen, und genau wissen, was gelöscht werden muss

http://trinityhome.org/Home/index.php?content=TRINITY_RESCUE_KIT____CPR_FOR_YOUR...

Antwort von Boelller,

was hast du denn auf AHCI 0 ?? vielleicht eine SSD? könnte eine fehleinstellung im bios sein oder du musst es updaten.

manchmal taucht der windows-bootmanager unter AHCI im bootmenü auf, dann kann der pc nicht booten (was soll das, scheisss microsoft??) da hilft dann eine neuinstallation.

oder festplatte/laufwerk macht probleme.... (SATA?)

Kommentar von i3asti2311,

Ich setze jetzt erstmal mein Windows neu auf, wenn das Problem danach immernoch bestehen sollte, nehme ich mir mal die Festplatte vor.

Kommentar von Boelller,

oke, wenns nicht klappt, zieh mal laufwerk und so komplett ab (strom! und info!), sodass nur noch die windows-festplatte dran ist.

Antwort von Botschamber,

Die Ursache sind deine Tools. Es gibt keines, das die Reg. zuverlässig reparieren würde und somit empfehlenswert wäre. Probier noch ein paar Tage rum, oder installiere gleich neu.

Wann, wo bzw. woher kommt überhaupt diese Fehlermeldung? Wenn das eine BIOS-Meldung ist, kann deine Festplatte defekt oder virenverseucht sein. Dann brauchst du eine Notfall-CD auf Linux-Basis.

Die Angabe der Hardware könnte auch nicht schaden.

Antwort von DerPianist,

Ich kann deine Problemlösungen nicht so ganz nachvollziehen - Du hast offenbar eine ganze Batterie an Hilfsprogrammen drüberlaufen lassen, ohne zu wissen, wo das Problem tatsächlich liegt.

AHCI hängt mit deinen SATA Anschlüssen zusammen. Deine Grafikkarte hat mit denen nichts zu tun, weil diese im Normalfall über PCIe angeschlossen ist. Der Port 0 ist in der Regel die erste Festplatte - von dieser wird im Normalfall auch gebootet.

Ich tippe darauf, dass du dir mit einem dieser "Helfer" inzwischen entweder dein Dateisystem zerschossen hast oder die Festplatte physisch kaputt ist.

Steht beim Hochfahren, wenn da noch der schwarze Bildschirm mit der weißen etwas altertümlich wirkenden Schrift ist zufälig irgendwo "S.M.A.R.T. Error" ?

Kommentar von i3asti2311,

Nein die Anzeige S.M.A.R.T. Error steht nirgendwo.

Kommentar von DerPianist,

Gut. Das hätte auf einen physischen Festplattendefekt hingewiesen.

Ansonsten schraub die Kiste mal auf, prüf ob beide SATA-Verbundungen fest sind (ist das der Fall, solltest du sie nicht einfach nach hinten rausziehen können, ohne den kleinen Klipp Ende des Kabels zu drücken). Prüf also an der HDD und am Mainboard.

Bringt das nichts, schau mal, ob du vielleicht am Mainboard einen anderen SATA-Anschluss nehmen kannst und dann von dem bootest - vielleicht ist ja der Port am Mainboard kaputt.

Hast du ansonsten noch die möglichkeit die Platte in einen anderen PC zu hängen, kannst du mal das Testprogramm von Western Digital drüberlaufen lassen.

Antwort von Gelb2012,

Wie der Kollege schon schrieb, AHCI ist ein Betriebsmodus zum ansteuern von SATA-Festplatten im nativen SATA-Modus.

Prüf mal die Verkabelung und prüf dann die Platte. Brauchst erst garkeinen Registry-Scan machen, das ist wohl weniger das Problem.

Saug dir mal HDtune oder irgendein anderes Programm, welches die Festplatte auf defekte Sektoren prüft und dir dabei eine grafische Anzeige in Form von Blöcken gibt.

Antwort von MajStealth,

ahci bezieht sich aber auf deine sata platte - vll solltest du mal im bios nachgucken was da für ein modus eingestellt ist

Kommentar von i3asti2311,

Ich bin ein ziemlicher Laie was das betrifft wie genau mache ich das am einfachsten?

Kommentar von MajStealth,

nach ner kurzen frage an google - was du auch hättest tun können - sagt mir google dass es auch sein kann dass sich deine platte verabschiedet - was hast du für einen hersteller von der platte und hast du noch garantie auf den rechner?

Kommentar von i3asti2311,

Nein ich habe keine Garantie mehr auf den Rechner da er schon etwas über 2 Jahre alt ist.

Kommentar von MajStealth,

hast du mitlerweile raus bekommen was für ein hersteller deine platte hat? die meisten bieten herstellerspezifische tools an die die platten auf fehler testen können

Du kennst die Antwort?

Fragen Sie die Community