Frage von HolgerleinF, 148

EXCEL: Berechnung ENTWEDER ODER?

Hallo ans Forum,

ich habe ein Excel-Problem und hoffe auf Eure Hilfe.

In einer Tabelle möchte ich folgende Berechnung anstellen:

steht z. B. in den Zellen B2 und B3 "HS", dann soll die Anzahl der "HS" (also 2) mit 20 multipliziert werden; hier Summe 40

es kann aber auch eine Zahl stehen (entweder 0,5 oder 1), dann soll das Ergebnis mit 24 multipliziert werden (also 0,5 + 1 * 24); hier Summe 36

Ich möchte ohne VBA-Programmierung möglichst EINE Excelformel in der Zelle B4, die das Ergebnis zeigt.

Kann mir da jemand weiterhelfen?

Und wie kann ich - möglichst online und schnell - ein paar Schulungen im Netz finden, die mir das Rechnen mit Formeln beibringen? :-(

Ich danke Euch für jeden Tipp.

LG HolgerleinF

Expertenantwort
von DeeDee07, Community-Experte für Excel, 104

Die Formel wäre dann

=ZÄHLENWENN(B2:B3;"HS")*20+SUMME(B2:B3)*24

Wenn in beiden Zellen "HS" steht, wird das Ergebnis 40 sein, wenn zwei Zahlen drinstehen, wird die Summe der Zahlen mit 24 multipliziert. Wenn einmal HS und eine Zahl steht, wird 20 + Zahl*24 gerechnet.

Eine gute Anlaufstelle für Formellernen ist z.B. http://www.online-excel.de/ (dort bei Funktionen). Fortgeschrittenere Formeln findest du bei http://excelformeln.de/formeln.html

Ansonsten würde ich mal die Funktionsliste von Excel durchstöbern und mir die Hilfe zu den einzelnen Funktionen durchlesen. Bei youtube gibt es auch viele Tutorials.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 86
=SUMME(WENN(ISTZAHL(B2:B3);B2:B3*24;0))+ZÄHLENWENN(B2:B3;"HS")*20

Mit Strg + Shift + Enter abschließen

Antwort
von Funfroc, 52

alternativ zum array

=WENNFEHLER(WENN(B2="HS";20;B2*24);0)+WENNFEHLER(WENN(B3="HS";20;B3*24);0)
Antwort
von dkilli, 59

Stehen die Werte HS immer nur in diesen beiden Zellen?  Steht 0,5 oder 1 nur in einer Zelle oder kann es auch in 2 Zellen stehen?

Um auf den Wert 36 zu kommen muss die Formel (0,5+1)*24 bzw (1+1)*24 lauten

Antwort
von dkilli, 45

Ich bin mir nicht sicher ob dir diese Formel zusagt, da du auf meine Fragen nicht geantwortet hast

=WENN(ZÄHLENWENN(B2:B3;"HS")>0;ZÄHLENWENN(B2:B3;"HS")*20;WENN(B2+B3>0;((B2+B3)+1)*24;WENN(B2+B3>0;((B2+B3)+1)*24;"")))

Antwort
von HolgerleinF, 49

TOP

Es funktioniert. ENDLICH!!!!! Vielen vielen Dank - nicht nur für die kompetente Antwort, sondern auch so flott.

HolgerleinF

Kommentar von dkilli ,

Welche Antwort hat dir am meisten geholfen?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten