Frage von Sibbe18, 731

Teilergebnis + Zählenwenn?

Diese Kombination der Formeln soll mir aus einer Datenbank alle €-Beträge die größer als null sind und alle €-Beträge die kleiner als 0 sind zählen NICHT SUMMIEREN. Die Werte befinden sich in Spalte M.  M8:M10000

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 674

Wenn du eine schnelle Lösung benötigst, könntest du eine Spalte in deiner Tabelle anlegen, in denen Einsen stehen, wenn der Betrag ungleich 0 ist.

Dann kannst du mit der Teilergebnisformel für die Summe (9) über diese Spalte summieren und somit die eingeblendeten Zeilen zählen, deren Betrag ungleich 0 ist.

Antwort
von DrFibuse, 600

Wäre die schnellste Lösung nicht "=ZÄHLENWENN(M8:M10000;"<>0")Funktioniert bei mir super.

Kommentar von Sibbe18 ,

nur leider aktuallisiert es sich nicht wenn ich nach beispielsweise einem Lieferanten filtere

Antwort
von Maboh84, 548

um was für eine DB handelt es sich denn?

Expertenantwort
von Ninombre, Community-Experte für Excel, 518

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:20)))*(A2:A20>0))

http://www.herber.de/forum/archiv/580to584/583782_Summewenn_und_Teilergebnis_kom... Formel etwas verkürzt, da Du nur die Anzahl und nicht die Summe willst.

Für die Werte kleiner Null halt <

Kommentar von Sibbe18 ,

kannst du erklären warum 2:20 ????? 

Kommentar von Iamiam ,

weil hier keiner aus Lust und Tollerei eine Tabelle mit 10000 Einträgen anlegt, nur um Dir die richtige Adresse zu liefern!

Soviel wirst Du doch noch selbst hinkriegen!??

Kommentar von Ninombre ,

Wenn ich ausprobiere, ob eine Formel funktioniert, fummel ich eine kleine Beispieltabelle zusammen. Du hast (als eine seltene Ausnahme bei den Fragen) tatsächlich genannt, wo Deine Werte stehen - die meisten machen das nicht, dann muss ich halt irgendwas annehmen. Im konkreten Fall wäre A bei Dir eben M und der Bereich 2:20 müsste 8:10000 sein.

Antwort
von dkilli, 351

=SUMMEWENN(A:A;">0")

=SUMMEWENN(A:A;"<0")

Gilt für  Excel und LibreOffice Calc

Kommentar von Sibbe18 ,

ich brauch das in kombi mit teilergebnis

Kommentar von Iamiam ,

Abgesehen davon, dass das ZÄHLENwenn heissen müsste: was soll der Blödsinn mit dieser Kombi? Von hinten durch die Brust ins Auge?

Wenns eine Hausaufgabe ist, dann schau in der Hilfe für Teilergebnis nach, oder weigerst Du Dich, was zu lernen?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten