Frage von IngoKlotz, 66

SVERWEIS oder WENN-Funktion?

Hallo,

ich soll in dieser Aufgabe Provisionen ausrechnen. Mit der WENN-Funktion geht es nicht, habe es schon probiert! Dann steht dort immer: "Zu viele Argumente"!

Für die Umsätze gelten folgende Provisionen:

ab 5.000 €, 2 % Provision

ab 6.000 €, 3 % "

ab 7.500 €, 4 % "

ab 9.000 €, 4,5 % "

ab 10.000 €, 5 % "

ab 12.000 €, 5,5 % "

ab 15.000 €, 6 % "

Expertenantwort
von Ninombre, Community-Experte für Excel, 39

Falls Du bei der Wenn-Formel bleiben will, dann fang mit der größten Zahl an, dass spart einiges an Logik ein, weil die zu erst gefundene gültige Bedingungen genommen wird. Du musst nicht mit < als x und > als y arbeiten.

=WENN(A2>15000;A2*0,06;WENN(A2>12000;A2*0,05;WENN(A2>10000;A2*0,05;WENN(A2<5000;A2*0))))

Der Betrag steht im Beispiel in A2 - ich habe nicht alle Varianten abgebildet, daher gibt es noch Lücken.

Alternativ und vermutlich einfacher per VERWEIS (der löst gefühlt ein Drittel der auf GF gestellten Probleme mit Excel)

=A2*VERWEIS(A2;{1;5000;6000;7500;9000;10000;12000;15000};{0;0,02;0,03;0,04;0,045;0,05;0,055;0,06})

Hier aber wieder unbedingt aufsteigend die Beträge und zusätzlich noch die Untergrenze für die es nichts gibt. Ich hab hier 1 eingesetzt.

Kommentar von Jackie251 ,

gut gemacht Ninombre

Keine passende Antwort gefunden?

Fragen Sie die Community