Frage von Ghanasoccer, 69

Kann man die Formel zur Überstunden / Minusstunden Berechnung durch eine gelungene benutzerdefinierte Formatierung ersetzen?

Also es gibt in der Tabelle IST (zB 35 Std) und SOLL (zB 45 Std). Wenn man das Berechnen lässt durch

=WENN(R4-S4>=0;TEXT(R4-U4;"hh:mm");TEXT(-(R4-U4);"[ROT]-hh:mm"))

(ROT geht leider nicht...) ( das > entspricht > )

kommen -10:00 raus.

gibt es eine Formatierung die es mir erlaubt auf diese Formel zu verzichten?

Anzeige
Antwort
von expermondo, 5

Hallo Ghanasoccer,

Schau mal bitte hier:
Zeit Excel

Expertenantwort
von DeeDee07, Community-Experte für Excel, 41

Die Formatierung wird nicht in den Formeln der Zelle erledigt, sondern per Zellformat oder bedingter Formatierung. Siehe auch hier, 4. Frage https://support.office.com/de-de/article/TEXT-Funktion-20d5ac4d-7b94-49fd-bb38-9...

Zellformatierung dürfte schwierig werden, da es sich um Text oder um negative Zeiten handelt.

Bleibt die bedingte Formatierung. Dafür verwendest du dann deine umgekehrte Prüfformel, also =(R4-S4)<0 in der BF.

Kommentar von Ghanasoccer ,

nur durch Zellformatierung also nicht zu schaffen...

Kommentar von Iamiam ,

doch! (s.m.AW)

Expertenantwort
von Iamiam, Community-Experte für Excel, 21

Wenn ich das richtig verstehe, willst Du ein Benutzerdefiniertes Format, das bei - (minus) keinen Gartenzaun zeigt?

Berechnen tut ein Format ja nichts, sondern nur darstellen, aber

das gibt es in vielen Variationen, zB::

[Blau]TTT, T.M.JJ h:mm;[Rot]-Standard;[Magenta]"-";[Farbe16]@

oder [Schwarz]+[h]:mm;[Rot]-0;[Magenta]°;[Blau]@

Letzteres dürfte für Überstunden das Beste sein.

Das zweite Format wird beim Öffnen auch in LO umgesetzt, nicht aber Formate, die sowas wie [Farbe7] (das wäre Magenta) enthalten.

Ich hab in xl aber keine über die Basisfarben hinausgehenden Farbnamen gefunden, die zB Dunkelgrün anders als [Farbe10] auszudrücken erlaubten, so dass auch die in LO unverändert übernommen werden könnten. Ist aber vllt gar nicht Dein Problem.

[Farbe18] ist in xl zB ein aufgehelltes Braun, Kannst rumprobieren. Geht entsprechend der alten xl-7-Farbliste bis 56, auch in neueren Versionen

Blaugrün wird als Blau gelesen und ohne weiteren Hinweis so gespeichert.

Du kannst auch die Grenze von 0 wegverschieben, wenn diuch sowas interessiert, stell eine neue Frage oder frag hier nach!

Kommentar von Ghanasoccer ,

Farben sind ja nicht so wichtig. ich wollte nur die Tabelle weitergeben, damit meine Mitarbeiter diese benutzen können und fals was kaputt geht auch wieder richten können (also auch mit wenig excelkenntnisse) . also wenn in der Zelle einfach eine Zeit minus der SOLL-Zeit steht und die negativergebnisse einfach als -[h]:mm ausgegeben weden und die positiven als [h]:mm reicht das vollkommen aus.

Kommentar von Iamiam ,

dIE NEGATIVEN WERDEN ALS EINFACHE mINUSZAHL 8IN tAGEN19 AUSGEGEBEN; wENNS H SEIN SOLLEN; DANN EBEN DOCH BESSER DIE tEXT-fORMEL1

Oder *wenn(Wert<0;-1:1), aber da ist die Irrtumsgefahr groß, dass man das - nirgends sonst bemerkt.

Keine passende Antwort gefunden?

Fragen Sie die Community