Frage von Fragender7899, 104

Excel doppelte WENN Formel?

Ich benötige eine doppelte Wenn-Funktion für die Berechnung eines Wertes (Je nachdem welche Währung in der Zelle C10 definiert ist soll in der Hilfstabelle "Statstik" der jeweilige Währungskurs berücksichtigt werden:

Hier die Formel =WENN(C10="EUR";B10Statistik!B22F18;B10F18;WENN(C10="USD";B10Statistik!B23F18;B10F18))

Es erscheint nun immer die Fehlermeldung "Sie haben zu viele Argumente für diese Funktion eingegeben".

Was mache ich falsch?

Expertenantwort
von Iamiam, Community-Experte für Excel, 67

streiche im äusseren Wenn das B10*F18, das ist zuviel. Stattdessen wird als sonst ja das zweite Wenn abgefragt und da drin ist diese Formel ja als sonst (wenn beide Bedingungen nicht zutreffen) schon aufgeführt. Also:

=WENN(C10="EUR";B10*Statistik!B22*F18;WENN(C10="USD";B10*Statistik!B23*F18;B10*F18))

die fetten Argumente sind die fürs Zutreffen der jeweiligen Bedingung.

Aber: ergibt das sonst als B10*F18 denn überhaupt einen Sinn, wenn kein Umrechnungsfaktor reinmultipliziert wird? Wärs da nicht besser, 0 oder einen Text wiederzugeben?

Ausserdem: Wenn das EUR bzw "USD" über die Zellformatierung reinkommt, wird es nicht erkannt, sondern nur, wenn es als Text in C10 steht (scheint aber der Fall zu sein)

(dass die * zu Kursiv umgesetzt werden, ist ein Relikt des alten Editors hier und nicht Dein Fehler. Immerhin erkennen ältere User daran, dass da mal ein * stand).

Expertenantwort
von DeeDee07, Community-Experte für Excel, 58

Beschreib mal in Worten und Zellbezügen, was die Formel machen soll.

Eine doppelte (verschachtelte) WENN-Formel kann z.B. so aufgebaut werden:

=WENN(1. Prüfung;1. Dann;WENN(2. Prüfung; 2. Dann;2. Sonst))

Das kursive ist das gesamte 1. Sonst

Antwort
von Willwissen100, 47

Du darfst nur drei Werte haben. Den WENN, DANN, SONST Wert. Du hast vier Werte in der ersten Formel. Die zweite Wenn Bedingung muss anstelle der ersten B10F18 stehen.

Antwort
von dkilli, 37

Die WENN Funktion funktioniert folgendermaßen:

Wenn(Prüfung;Dann Wert;Sonst Wert)

Wenn(C10="EUR";Dann mache dies;Sonst mache jenes)

Was meinst du mit B10StatistikB22F18 ???

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten