Frage von Matjes1703, 85

Excel Benutzerdefinierte Zellenformatierung: Wie kann ich kleine zahlen in milli mikro nano pico ... anzeigen?

Ich habe in Excel 2013 Zeitmessungen (Phasenverschiebungen) die im Bereich von 0,001 bis ca 0,000005 sekunden liegen. Ich möchte jetzt passend dazu zB anstatt "0,005" einfach "5 milli" oder "5 ms" angezeigt kriegen.

Mit Exponenten wirds einem ja von Excel schon angeboten aber ich möchte direkt "milli" oder "mikro" bzw eben "m" und "µ" angezeigt kriegen.

Ich kriegs einfach nicht hin die Formatierung so hinzubasteln... Für den Frequenzbereich hab ich was gefunden aber das liegt im Klio und mega Bereich...

Man sollte meinen dass man sowas auf Anhieb bei Google findet aber ich finde dazu leider nichts. ? :-(

Expertenantwort
von Iamiam, Community-Experte für Excel, 79

Als Format:

Direkt in derselben Zelle krieg ichs nicht hin, nur in einer Abhängigen Zelle.

Wert wieder in A1.

in A2: =WENN(ABS(A1)<10^-9;A1*10^12;WENN(ABS(A1)<10^-6;A1*10^9;WENN(ABS(A1)<10^-3;A1*10^6;WENN(ABS(A1)<1;A1*10^3;A1))))

A2 Grundformatierung Bendef : 0,0" s";[Rot]-0,0" s" (beachte: das ist KEINE Zeitformatierung, also nicht die Einheit Tag=1, sondern 1 ist 1 s und könnte auch Salzfass bedeuten.

Jetzt bedingte Formatierung - neue Regel- wählen. Typ: Formel verwenden

Formel: =abs(A1)<1  Format: 0,0" ms";[Rot]-0,0" ms"

Neue Regel: Formel: =ABS(A1)<10^-3  Format: 0,0" µs";[Rot]-0,0" µs"

N.Regel: Formel: =ABS(A1)<10^-6  Format: 0,0" ns";[Rot]-0,0" ns"

N.Regel: Formel: =ABS(A1)<10^-9  Format: 0,0" ps";[Rot]-0,0" ps";[Farbe7] °" ps"

Achte darauf, dass am Schluss die oberste Regel ps, die unterste ms hat.

Das jeweilige Kästchen "anhalten" hab ich leer gemacht, bin da noch nicht schlau draus geworden, funktioniert aber ohne Haken.

Der Bezug in der bedingten F'g ist OHNE $-Zeichen und deshalb relativ kopierbar. -an der Darstellung "bezieht sich auf" =$A$2 kannst du nichts ändern.

Beachte: der Wert zB Zahl * ms stimmt, aber die zahl stimmt um die entsprechenden Zehnerpotenzen nicht mit der Ausgangszahl überein, könnte mal Verständnisprobleme geben.

Bei der zuletzt eingegebenen (im Ergebnis obersten) Regel für ps macht eine besondere Nulldarstellung Sinn, sonst nirgends. Als Nulldarstellung bevorzuge ich ein unauffälliges magentafarbenes Zeichen, hier den °-Kringel. Das erlaubt, eine glatte 0 von einer gerundeten 0 zu unterscheiden und stört andererseits bei Wahr-Falsch-Listen nicht: besser unterscheidbar von der 1.

Noch ein Tip: das Bendef F'at

#.##0,000" "000" "000" "000;[Rot]-#.##0,000" "000" "000" "000;[Farbe7]°

trennt die Nullen in Dreiergruppen, könnte für Deine Zahlen nützlich sein!

Expertenantwort
von Iamiam, Community-Experte für Excel, 72

als Formel (Umwandlung zu Text):

=WENN(A$1<10^-9;TEXT(A$1*10^12;"0,0;-0,0;0")&" picosec";WENN(A$1<10^-6;TEXT(A$1*10^9;"0,0;-0,0;0")&" nanosec";WENN(A$1<10^-3;TEXT(A$1*10^6;"0,0;-0,0;0")&" µsec";WENN(A$1<1;TEXT(A$1*10^3;"0,0;-0,0;0")&" millisec";TEXT(A$1;"0,0;-0,0;0")&" sec"))))

Der Text (in B1) müsste dann aber so wieder zur Zahl umformuliert werden: (bei Beibehaltung der umgewandelten Einheit - für die ursprüngliche Einheit steht ja das Original):

=LINKS(B1;FINDEN(",";B1;1)+1)*1 

über Weiterungen sinne ich gerade noch nach, zB das als reines Format darzustellen, da könnte auch was gehen.

Keine passende Antwort gefunden?

Fragen Sie die Community