Zelle nach Großbuchstaben durchsuchen

4 Antworten

Angenommen in A2 steht der Text. Dann mal mit folgender Formel versuchen.

=SUMMENPRODUKT((CODE(TEIL(A2;ZEILE($A$1:INDEX(A:A;LÄNGE(A2))); 1))>=65)*(CODE(TEIL(A2;ZEILE($A$1:INDEX(A:A;LÄNGE(A2))); 1))<=90))

Sonderzeichen Ü A Ö sind noch nicht berücksichtigt. Aber kann man ja dann erweitern.

Ich habe mal etwas gebastelt. War aber recht aufwendig. Hoffentlich ist es das, was du suchst. Du musst die Formeleingabe als Matrixformel mit [Strg]+↵ abschließen.

=SUMME(ABS((CODE(TEIL(A1;ZEILE(INDIREKT("$1:$"&LÄNGE(A1)));1))-65)<=26)*1)

In A1 steht bei mir der Text.

Wenn du Fragen hast, stell sie bitte gleich, bevor ich mich da nochmal einarbeiten muss.

DH!

Schöne und funktionierende Lösung.

0
@DeeDee07

Das ABS ist noch nicht ideal (hätte ich mir schenken können). Klein- und Großbuchstaben werden zwar unterschieden, aber Zahlen und Sonderzeichen können Probleme machen...

Es fehlt eine Funktion "ISTZWISCHEN".

Hat man diese nicht, muss man es wie merkurus machen und die komplette Rutsche (CODE...) mehrmals durchlaufen. Will man ÄÖU auch noch berücksichtigen, schreibt man sich einen Wolf und der Computer rechnet sich einen.

Habe eine Idee...

0
@Suboptimierer

Das dürfte die bessere Alternative sein:

=SUMME(NICHT(ISTFEHLER(FINDEN(TEIL(A1;ZEILE(INDIREKT("$1:$"&LÄNGE(A1)));1);"ABCDEFGHIJKLMNOPQRSTUVWXYZÄÖÜ")))*1)

(wieder Matrixformel)

4

Vielen Dank für eure schnelle Antworten :) funktioniert alles einwandfrei :)

Was möchtest Du wissen?