zeilen beim kopieren aufrücken lassen!

...komplette Frage anzeigen gesamt - (Excel) datum1 - (Excel)

5 Antworten

Ein automatisches Aufrückenlassen wäre theoretisch machbar, aber sehr aufwändig. Die Funktion, die du dann verwenden müsstest, nennt sich BEREICH.VERSCHIEBEN. Aber vielleicht reicht es ja, wenn du (ausgehend vom letzten Stand) die leeren Zeilen in den Tabellen datum1 und datum2 ausfilterst?

Allerdings hat das normale Filtern einen Haken: Wenn du die leeren Zeilen bei "Eingang" filterst, sind auch die Zahlen bei "Ausgang" weg (außer sie stehen zufällig neben einem Eingang). Dafür gibt es den "Erweiterten Filter" bzw. "Spezialfilter". Im folgenden das Vorgehen bei Excel 2007/2010:

  • Auf dem Blatt "gesamt" schreibst du in J1 das Wort Ausgang, in K1 das Wort Eingang (so wie es in G1 und H1 steht).
  • In die Zellen J2 und K3 tippst du jeweils die Formel =">0".
  • Dann markierst du die Zellen J1 bis K3 und tippst im Namensfeld (über dem Spaltenkopf von Spalte A) als Name für diesen Bereich das Wort "Filter" (ohne Anführungszeichen)
  • Nun kannst du in den Tabellen datum1 und datum2 filtern: In der Multifunktionsleiste "Daten", Gruppe "Sortieren und Filtern", klickst du auf "Erweitert".
  • Es öffnet sich das Dialogfeld "Spezialfilter". Darin legst du oben die Option "An andere Stelle kopieren" fest.
  • Vergewissere dich, dass bei "Listenbereich" der gesamte Datenbereich eingetragen ist ($A$1:$D$30).
  • Als "Kriterienbereich" trägst du wieder das Wort Filter ein.
  • Im Feld "Kopieren nach" legst du den Bereich "$F$1:$I$30" fest und schließt das Dialogfeld mit "OK". Damit ist der Filter gesetzt; die gesuchten Werte sollten nun in F2:I13 stehen.
  • Wenn du nun noch die Spalten A bis E ausblendest (Spaltenbreite 0), ist die "Täuschung" perfekt ;-)

Viel Erfolg beim Nachbauen!

richtoldi 05.09.2012, 21:38

Noch eine Anmerkung: Diese Filtermethode kopiert nur die Werte aus der ursprünglichen Tabelle (in diesem Fall A1:D30) an die angegebene Stelle, aktualisiert sich aber später nicht mehr, wenn sich die Werte in den Spalten A:D ändern. D.h. nach einer evtl. Änderung im Blatt "gesamt" du musst die Filterung auf den Blättern "datum1" bzw. "datum2" erneut durchführen.

Die fertige Datei habe ich hier hochgeladen: http://www.herber.de/bbs/user/81723.xls

Ich hoffe, damit wird es noch etwas verständlicher.

0

Hiho

wenn ich das richtig verstanden habe:

du willst bestimmte Spalten mit einem Bezug kopieren ohne dass der Bezug verloren geht

am besten kopierst du alles in ein neues blatt und markierst du die spalte die wegsoll (einfach auf den grauen buchstaben über der ersten zeile klicken zb B) dann:

rechte maustaste auf den buchstaben der spalte > zellen löschen

dann rücken die zellen zusammen ohne dass der zellbezug verloren geht (bzw wird der zellbezug automatisch angepasst)

das wiederholst du einfach mit allen spalten die du nicht brauchst

mfg the wookie

ah ich seh schon

du hast folgende formel benutzt:

=WENN(ODER(gesamt!D3;gesamt!E3)<>"";gesamt!B3;"")

es muss aber heissen:

=WENN(ODER(gesamt!D3<>"";gesamt!E3<>"");gesamt!B3;"")

wenn du dass dann noch untereinander haben willt kannste das mit

Ganze Tabelle Markieren > TAB: Daten > Filtern > auf Artikelnummern Klicken > Von A bis Z Filtern

warrior23 05.09.2012, 11:18

ja das ist schon richtig, aber in dem reiter datum1 sieht man dass unnötige zeilen die in den reiter datum2 gehören, kopiert wurden, die zeilen in denen #wert steht, wie kriege ich das hin dass die daten in den reiter datum1 kopiert werden, die wirklich da rein gehören??

0
chewbacca55 05.09.2012, 12:22
@warrior23

ja das #wert verschwindet wenn du die formel änderst wie ich es dir gesagt habe

und dann filtern wie ich es gesagt habe dann stehen alle untereinander

bei mir klappts

sonst weiss ich nicht was du meinst

0
warrior23 05.09.2012, 13:09

ersmal danke für deine antworten, bin jetzt beim prüfen, dann melde ich mich!

0
warrior23 05.09.2012, 13:44
@warrior23

so hier bin ich wieder, ich hab alle formeln korriegiert wie du mir empfohlen hast, #wert ist jetzt weg, aber da wo #WERT stand möchte ich die zellen vom reiter gesamt nicht kopieren, jetzt stehen die im reiter datum1 leer. konkret: ich möchte in den reiter datum1 und datum2 nur belegte zellen übertragen.

0
chewbacca55 10.09.2012, 18:27
@warrior23

gut, die zellen sind aber leer also kannste mit filter die leeren zellen einfach nach unten schieben wo sie nicht stören und den rest sortieren

0

mir ist deine Fragestellung noch nicht ganz klar, kannst versuchen das nochmal genauer darzulegen was du möchtest

also ich hab mir jetzt mal was anderes ausgedacht:

http://host-a.net/u/chewbacca55/81706neu.xls

is zwar jetzt mit einer übergangstabelle aber es is automatisch und für mehr fehlt mir die lust

kannst es ja umherschieben mit Ausschneiden wie du möchtest

mfg The wookie

warrior23 06.09.2012, 12:56

erstmal danke für Eure Bemühungen, aber ich möchte keine zusätzlichen tabellen oder zusatzdaten oder extra sortier optionen in den reitern datum1 und datum2, möchte einfach (nicht so einfach) per formel in in reiter das relevante kopieren!

0

Was möchtest Du wissen?