Zahlen vergleichen und sortieren in Excel 2010

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Wenn ich das Problem richtig verstehe ...

ist Spalte A mit Spalte B zu vergleichen, ob der Sollwert (Sp B, angenommener Bestand) in Spalte A (Istwert) vorhanden ist.

Dann hilft Dir in Spalte C

=INDEX(A:A;VERGLEICH(B:B;A:A;0))

Bei Vorhandensein wird Sp C der Wert aus Sp A angezeigt, bei Nichtvorhanden: #NV

Sollte ich mit meiner Vermutung falsch liegen, melde Dich nochmal.

Reicht das ?

Gruß aus Berlin

Woher ich das weiß:Hobby – Jahrelanges programmieren.
Spalten_Vergleich - (Excel, Zahlen, Sortieren)

Genau das! Danke vielmals! Tag gerettet :)

0

Britzcontrol - also vielen vielen Dank für die Hilfe - das war auf jedenfall schonmal eine riesen arbeitserleichterung :)

Jetzt hätte ich noch eine frage zum Abschluss. Ist es denn möglich - die werte aus Spalte A die NICHT in B vorkommen irgendwie hervorzuheben gleichzeitig (oder von mir aus in einer Spalte D) ??

0

Dann nutze doch besser die Bedingte Formatierung (Zellhintergrund grüne Füllfarbe: hellgrün Sp A, grün Sp B).

Für Sp A: =VERGLEICH(A1;B:B;0)

Für Sp B: =VERGLEICH(B1;A:A;0)

Dann werden Werte, die in beiden Spalten sind, farbig (entsprechend der eingestellten Formatierung) bzw. bleiben farblos, wenn in der anderen Spalte nicht vorhanden.

Gruß aus Berlin

1

irgendwie ist mir noch nicht ganz klar, was du machen willst. Wenn es um Bestände geht, müsstest du dann nicht noch irgendwo eine Spalte heben mit der Artikelbezeichnung oder wenigstens einer Artikelnummer?

Mit den Formeln "Index" und  "Vergleich" kannst du Spalten umsortieren, meist brauchst du noch eine Hilfsspalte dazu, aber konkret kann ich dir das jetzt nicht in eine Formel fasen

Ich hab das ganze versucht in einer Antwort etwas besser zu erklären :)

0

Ok ich versuche es nochmal zu erklären.

Ich muss die "Seriennummern" Vergleichen. Es gibt eine Auflistung dessen was ich wirklich habe und eine Auflistung was ich angeblich habe.

A=das habe ich (einfache nummernfolge = 900012345 zB.)

B=das habe ich angeblich (einfache nummernfolge = 900012345 zB.)

Ich brauche jetzt in Spalte C die Nummern die ich habe (A) zu den Nummern die ich Angeblich habe (B) sortiert in eben Spalte C. 

Dann kann ich händisch weitermachen und das ganze entsprechend weiter aufdröseln. Eine Artikelbezeichung etc. brauche ich nicht, das ist alles im System nachvollziehbar.

Und falls möglich - Ergebnisse (Zahlenwerte) die in A stehen aber nicht zu B passen, "unten" unsortiert dranhängen (falls dies möglich ist)

Oder von mir aus auch B sortieren nach A und dann ist nach dem letzten Eintrag von A nur noch B random die Restwerte. Ich kann mit jedem dieser Ergebnisse arbeiten, ich muss nur zu einem von diesen kommen :)

Vielen vielen Dank schon mal im vorraus

0

Was möchtest Du wissen?