Zählen wenn Datum im Zeitraum liegt - was mache ich falsch?

...komplette Frage anzeigen

1 Antwort

Zählenwenn akzeptiert nicht ohne weiteres aufwendigere Bedingungen.Ich löse so etwas immer mit SUMMENPRODUKT:

=SUMMENPRODUKT((C2:C765>=F1)*(C2:C765<G1))

Vielen Dank! Es klappt, aber nur als Verständnisfrage, wozu wird in der Formel "*" (multipliziert?) genutzt? Scheinbar erstetzt es das "UND" aus meiner alten Formel, oder? Eigentlich ist der Aufbau sehr gleich, doch was genau bewirkt die SUMMENPRODUKT-Formel im  Vergleich zur ZÄHLENWENN-Formel?

Vielen Dank für deine Hilfe!!!! :-)

0
@Coregan

Du hast Recht, das "*" ersetzt quasi das UND.
Es geht hierbei um Wahrheitswerte.
(C2:C765>=F1)
z.B. gibt entweder WAHR oder FALSCH zurück.
Dabei ist für EXCEL WAHR gleich 1 und FALSCH gleich 0.
Entsprechend für die andere Bedingung.
NUR wenn beide Bedingungen WAHR, also 1 sind ergibt das Produkt
1 * 1 = 1
Sobald mindestens eine der Bedingungen FALSCH, also 0 ist, ist auch das Ergebnis 0.
Das wird für jede Zeile gemacht und die Ergebnisse zusammengezählt.
Kannst Du das nachvollziehen. Sonst frage nochmal nach, ich habe im Moment leider keine Zeit mehr, schaue aber morgen früh nochmal vorbei.

2
@Oubyi

P.S.: Ein "+" statt des "*" ist dann übrigens die Entsprechung für ODER.

0
@Oubyi

Hallo Oubyi, deine Erklärung leuchtet mir ein. Vielen Dank für deine Mühe, du hast mir sehr geholfen!! :-)

0
@Oubyi

Hallo Oubyi, ich habe noch eine kleine weitere Frage... für eine erweitere Auswertung meiner Liste würde ich gerne die bisherige Formel um eine weitere Bedingung erweitern.

Das bedeutet im Klartext: Ich habe eine Liste von Ereignissen die in einem Land passiert sind und möchte nun nach Zeitraum und Land filtern.

=SUMMENPRODUKT((Tabelle1!$C$2:$C$1672<D$3)(Tabelle1!$C$2:$C$1672>=C$3)(Tabelle1!$I$2:$I$1672=$B4))

Dabei stehen D3 und C3 für das Datum und B4 für mein Land (String)

Ich habe überlegt dies mit einer einfachen wenn-funktion zu erweitern doch dies ist leider nur bei einer einzelnen Abfrage und nicht einem Bereich von >1600 möglich... hast du oder vielleicht jemand anders eine idee wie dies realisierbar ist?

0
@Coregan

Das verstehe ich jetzt nicht. Warum passt denn Deine Formel
=SUMMENPRODUKT((Tabelle1!$C$2:$C$1672<D$3)*(Tabelle1!$C$2:$C$1672>=C$3)*(Tabelle1!$I$2:$I$1672=$B4))
nicht? Was macht die falsch?

0
@Oubyi

Sie berechnet leider nicht richtig, wird manuel in der Tabelle gefiltert, nach dem gewünschten Ergebnis, gibt es Differenzen zwischen -1 bis +2.. Was die Formel genau falsch macht, habe ich noch nicht herausgefunden.

0

Was möchtest Du wissen?