XAMPP trotz freien Port bockig?

2 Antworten

Wenn du sicher bist, dass Port 80 frei ist, dann überprüf mal, ob dieses Panel mit Adminrechten ausgeführt wird. Port 80 ist ein sogenannter privilegierter Port (Ports 0-1024), der nur mit Adminrechten belegt werden darf.

23

Laut dem Konsolenbefehl netstat ist Port 80 frei.

Das Panel habe ich mit Adminrechten ausgeführt, auch die Installation verlief mit Adminrechten und mein Antivirenprogramm war während der Zeit ausgeschaltet. Skype benutzt Port 80 ebenfalls nicht.

Allerdings bekomme ich jetzt solche Meldungen.

http://fs5.directupload.net/images/160421/4palqi2f.png
http://fs5.directupload.net/images/160421/76ga5vgq.png

0
36
@abbrechen

xampp installiert einen windows service. dieser erwarted die httpd.exe an einem anderen ort. (Bild1)

xampp möchte lieber nicht in C:\Programme installiert werden, da es dann zum Ändern von Dateien innerhalb des eigenen Verzeichnisses immer eine UAC Anfrage (das ding das den bildschirm verdunkelt und fragt ob du das wirklich mit adminrechten tun willst) braucht.

Mein Vorschlag: Deinstalliere xampp und alles was mit xampp zu tun hat. deinstalliere auch den windows service. (wie das geht: http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-windows-service-in-vista-or-xp/ - nur musst du den namen des xampp/httpd services nehmen)

Dann installiere xampp noch mal frisch direkt nach C

0
36
@RakonDark

Die httpd.exe ist Bestandteil von xampp. Die Redistribute Libs brauchst du nur, weil der httpd mit visual c++ compilliert wurde. ha also mit dem problem nix zu tun.

0
23
@TheQ86

Weisst du zufällig, welcher Windows Service genau deinstalliert werden soll? Einen Dienst namens httpd, xampp o.ä. fand ich nicht.

Hatte bei der Suche nach dem richtigen Service auch eine Anleitung gefunden, dass man in einer Config-Datei die Bennenung "List 80" auf 81 ändern kann, damit xampp Port 80 in Ruhe lässt. Leider ohne Erfolg.

0
23

Nun, Stand der Dinge: Ich habe xampp in der Partition E installiert. Seit dem kommen auch keine Meldungen bezüglich des Pfades mehr (Bild 1) und xampp zeigt mir nun an, welche Dienste installiert sind und welche nicht. Doch möchte ich Apache starten, besteht noch das selbe Problem.

Bei der Reinstallation habe ich vom xampp-Installer den Tipp bekommen, das UAC zu deaktivieren, leider scheint das nichts gebracht zu haben.

0

1. vielleicht mit "ausführen als Admin" starten .

2. neuinstallieren

Frage : lieft ds ding überhaupt schon .

Frage : woher weisst Du das Port 80 frei ist ?

3. Port 8080 ausprobieren .

23

Mit der Neuinstallation hat das nicht geklappt. Dabei hatte ich XAMPP gründlich entfernt.

Nein, lief noch nicht.

Ich hatte über den Konsolenbefehl netstat nachgesehen und den entsprechenden Dienst ausgeschaltet. Auch Skype, das gerne Port 80 verwendet, darf ihn nicht mehr verwenden.

Bei der Neuinstallation und während des Startes war mein Antivirusprogramm ausgeschaltet.

Wie kann ich Port 8080 für XAMPP einsetzen? In den Einstellungen fand ich keine entsprechende Option.

Ich bekomme nach der Installation nun folgende Meldungen. 

http://fs5.directupload.net/images/160421/4palqi2f.png
http://fs5.directupload.net/images/160421/76ga5vgq.png

0
27
@abbrechen

hab ich auf die schnelle keine ahnung , ich mochte xamp noch nie und benutze wamp , das funktioniert wenigstens ohne irgendwelche zusatzeinstellungen .

0

Apache startet nicht auf El Capitan?

Hey Leute. Ich habe El Capitan Version 10.11.5 (15F34) und will über XAMPP ein MagentoShop Simulieren. Letzteres will ich über ein Bitnami Package machen.

Problem ist das ich über XAMPP weder Apache noch MySQL starten kann. Ich habe versucht Apache über das Terminal zu starten. Alles ausser " sudo /Applications/XAMPP/xamppfiles/bin/apachectl start" hat nicht funktioniert. Direktes ansprechen mit "sudo apachectl start" etc. ist nicht möglich gewesen.

Nun da Apache On war, habe ich versucht das Magento Packet drauf zu hauen. Während der Installation hatte ich dann auf einmal nicht die erforderlichen Rechte ( bin Admin ) um das Packet in den XAMPP Ordner zu hauen der in Applications liegt. Vor dem Start von Apache ging das, die Installation ist natürlich daran gescheitert das Apache nicht erreichbar war ( dachte bis dahin das beim h hochfahren des Systems Apache automatisch startet....). Nach Neustart des Systems, habe ich nun das Problem das Apache wieder nicht startet und -der Terminal spuckt mir aus das ich nicht die nötigen Rechte besitze. Über die XAMPP Applikation geht auch nix mehr (??). Ich kann nicht einmal den Port ändern . . . :-/

Hatt jemand deinen konstruktiven Vorschlag/Tipp für mich?

Danke euch...!

...zur Frage

XAMPP läßt sich nicht von Laufwerk c: löschen...

Ich habe XAMPP über die Systemsteuerung gelöscht...nun ist der Ordner noch unter dem Laufwerk C: und hat die 3 Ordner (mercuryMail, mysql, tmp) noch drin. (Windows 7 ) Wenn ich jetzt auf XAMPP gehe und mit der rechten Maustaste drücke um dort auf löschen zu gehen kommt folgende Fehlermeldung: Die Aktion kann nicht abgeschlossen werden, da der Ordner (oder eine Datei darin) in einem anderen Programm geöffnet ist.

Aber ich habe alles geschlossen - Rechner neugestartet --- aber die Fehlermeldung kommt immer wieder....????!????

Was muss ich machen um XAMPP nun ganz zu löschen???

Ziel ist eigentlich es neu zu installieren....da Apache nicht startet...ich habe Skype wegen der PORT 80 geschichte gelöscht....-geht nicht---- habe es auch einfach XAMPP neuinstalliert---- Appache geht immer noch nicht......es soll ein Magento Shop installiert werden..

Bitte eine verständliche Erklärung --Schritt für Schritt = bin kein IT ler - nur Anwender....****

...zur Frage

Was möchtest Du wissen?