Wordpress URL mit Beitragsnamen funktionieren nicht?

... komplette Frage anzeigen

3 Antworten

Hallo,

mod_rewrite muss auch als Apache-Modul an sein, nicht nur in der htaccess. Da wird dir dein Hoster bestimmt weiterhelfen können ob das aktiviert ist.

Danach Server evtl. neustarten und in Worppress bei den Permalinks-Settings das ganze nochmal abspeichern, damit es neu aufgebaut wird.

Hoffe das hilft.

Antwort bewerten Vielen Dank für Deine Bewertung

Ich möchte eine kurze Rückmeldung geben, damit Leute die dieses Problem auch plagt und an alle, die versucht haben mir zu helfen bescheid wissen. Die Problemlösung war im Endeffekt sehr einfach. Ich musste lediglich  "a2enmod rewrite" als Root ausführen und den Webserver dann neustarten. Vielen Dank an all! :)

Antwort bewerten Vielen Dank für Deine Bewertung

Könnte ein Problem mit der .htaccess-Datei sein.

Lege eine solche Datein mit dem Inhalt an, den Du auf dem angehängten Bild siehst.

Dann lade die .htaccess-Datei ins Root-Verzeichnis Deines Servers.

Lass mich bitte wissen, ob's geklappt hat. Danke.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von thunderbird304
28.03.2016, 14:00


Vielen Dank für die Antwort. Leider war es nicht die Lösung. Die .htaccess Datei hatte ich schon, auch mit genau dem Inhalt. Sobald ich wieder Permalinks wie "domain.de/beitragxy" verwende kommt Fehler 404. Natürlich hat die htaccess auch genügend Rechte.




Not Found

The requested URL xxx was not found on this server.


Apache/2.2.22 (Debian) Server at xxx.de Port 80


Bei "xxx" stand natürlich der Link den ich hier aber ungerne posten möchte.



0

Was möchtest Du wissen?