Wo ist der Fehler in folgender Excel-Formel?

... komplette Frage anzeigen

3 Antworten

Da die Summen Funktion Textfelder ignoriert kann man sie neben den bereits genannten Lösungen auch für den Zweck "missbrauchen".

=WENN(SUMME(D5)>0;D5;WENN(SUMME(E5)>0;E5;""))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von darkhouse
05.04.2016, 10:22

Die kompakteste und eleganteste Lösung, danke! Erspart mir, die vielen Nullen bedingt zu formatieren und "unsichtbar" zu machen...

0

Prüf mal, ob in D evtl. ein Leerzeichen steht. Das wäre der Bedingung nach auch größer 0, so dass der Sonst-Zweig mit E>0 nicht zum Einsatz kommt.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von darkhouse
04.04.2016, 10:39

Bingo! Danke. Hab in D 0 eingetragen, schon klappt's. Muss ich eben eine weitere Bedingung einarbeiten. Nichts ist bei Excel also größer als Null, na ja, wieder was gelernt...

Ach nee, da steht nicht nichts drin, sondern eine Formel mit dem Ergebnis Leerschritt. Also doch was. Muss ich also nur umschreiben...

0

wahrscheinlich hast Du in D5 eine Formel stehen, die "" ergibt. Das ist ein Text, -wenn auch leer- und Texte sind größer als jede von xl rechenbare Zahl.

(Demo: in A1: ="", in B1:=A1>0 ergibt WAHR )

Lösung: =Wenn(und(D5<>"";D5>0);...  

oder =Wenn(und(istzahl(D5);D5>0);...

Du kannst aber auch in D5 als sonst-Argument 0 ausgeben und das per Zellformatierung entweder unsichtbar machen oder als unauffälliges Zeichen darstellen. Beim Zellformat darfs "" sein, denn da ist es nur die Darstellung:

Bendef Format (Strg+1, Zahlen, Benutzerdef.): 0;[rot]-0;""

oder (unauffälliges Symbol für 0): 0;[rot]-0;[Farbe7]°

Dann kannst Du Deine Formeln ansonsten unverändert übernehmen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
04.04.2016, 11:39

ich würde eher Standard;Standard;; nehmen - auch wenn hier ggf lediglich natürliche Zahlen auftreten, zu schnell wird das Format auch auf Zellen ausgeweitet und plötzlich werden die Nachkommastellen in der Anzeige weggerundet in der Zelle jedoch nicht

1

Was möchtest Du wissen?