Wieso funktioniert mein Plugin nicht (Fehlermeldung)?

5 Antworten

Wie wäre es mal mit einem pastebin-Link von deiner plugin.yml?
Andernfalls könntest du mit dem YML-Parser checken, ob die Datei (was das YML betrifft) richtig formatiert ist: http://www.yamllint.com/

Ich bin keine Plugin Dev, aber trotzdem sehe ich, dass deine plugin.yml falsch ist.
YAML/YML achtet immer aufs extremste auf tabulatoren. Guck mal, ob Tabulatoren durch Leerzeichen ersetzt sind, und behebe diesen Fehler

Hallo ich habe ein Minecraft-bukkit-plugin Programmiert in Eclipse bekomme ich keine fehler aber in der Konsole (Das Plagin ist ein InvetarKitsPlugin) Error:?

[15:50:14 ERROR]: Could not pass event InventoryCreativeEvent to ItemsKit v1.0 org.bukkit.event.EventException at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:302) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav a:62) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.j ava:501) [bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j ava:486) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java :1710) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PacketPlayInSetCreativeSlot.a(SourceFile :23) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PacketPlayInSetCreativeSlot.a(SourceFile :9) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:1 3) [bukkit.jar:git-Bukkit-18fbb24] at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [ ?:1.8.0_71] at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_71] at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [bukkit.jar :git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:6 73) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:3 35) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:6 29) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java :537) [bukkit.jar:git-Bukkit-18fbb24] at java.lang.Thread.run(Unknown Source) [?:1.8.0_71] Caused by: java.lang.IllegalArgumentException: Specified enchantment cannot be a pplied to this itemstack at org.bukkit.inventory.ItemStack.addEnchantment(ItemStack.java:440) ~[b ukkit.jar:git-Bukkit-18fbb24] at Kits.Kits.Inventory(Kits.java:31) ~[?:?] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0 _71] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0 _71] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1 .8.0_71] at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_71] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:300) ~[bukkit.jar:git-Bukkit-18fbb24] ... 15 more [15:50:15 ERROR]: Could not pass event InventoryCreativeEvent to ItemsKit v1.0 org.bukkit.event.EventException at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:302) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav a:62) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.Si

...zur Frage

Bukkit Fehler: (Is it up to date)?

Ich habe ein Plugin programmiert das bis vor kurzer Zeit noch funktionierte aber jetzt kann man nicht mehr damit machen in der Konsole kommt der Fehler:

    [15:59:18 ERROR]: Error occurred while enabling System v4.0 (Is it up to date?)
java.lang.NullPointerException
        at de.lolermc.Main.registerCommands(Main.java:136) ~[?:?]
        at de.lolermc.Main.onEnable(Main.java:52) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

Meine Main.java:

http://pastebin.com/QDer8uiF

Kann mir jemand Helfen? Es ist sehr dringen

...zur Frage

Kann jemand diesen Fehlercode lesen?

Es ist eine Bukkit Plugin das ich schreibe. hier der Fehlercode aus dem log:

[17:20:19] [Server thread/ERROR]: Could not load 'plugins\test.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/Hauke/main/main : Unsupported major.minor version 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.java:291) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:199) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at java.lang.Thread.run(Unknown Source) [?:1.7.0_04] Caused by: java.lang.UnsupportedClassVersionError: me/Hauke/main/main : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_04] at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_04] at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_04] at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_04] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_04] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_04] at java.lang.Class.forName0(Native Method) ~[?:1.7.0_04] at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_04] at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214]

...zur Frage

Was bedeutet dieser Fehlercode(Java, Minecraft, Plugin)?

Error occurred while enabling nick v1.0 (Is it up to date?)
--:--:-- java.lang.NullPointerException
--:--:-- 	at de.georgy.main.Main.registerCommands(Main.java:31) ~[?:?]
--:--:-- 	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at de.georgy.main.Main.onEnable(Main.java:17) ~[?:?]
--:--:-- 	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]
--:--:-- 	at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]

...zur Frage

Was heißt diese Fehlercode beim Skywars Reloaded Plugin?

[Skywars] Task #425 for Skywars v3.4.2-Snapshot generated an exception
--:--:-- java.lang.ClassCastException: org.bukkit.craftbukkit.v1_8_R3.block.CraftBlockState cannot be cast to org.bukkit.block.Chest
--:--:-- 	at com.walrusone.skywarsreloaded.menus.gameoptions.ChestOption.completeOption(ChestOption.java:118) ~[?:?]
--:--:-- 	at com.walrusone.skywarsreloaded.managers.MatchManager.startMatch(MatchManager.java:324) ~[?:?]
--:--:-- 	at com.walrusone.skywarsreloaded.managers.MatchManager.access$100(MatchManager.java:42) ~[?:?]
--:--:-- 	at com.walrusone.skywarsreloaded.managers.MatchManager$3.run(MatchManager.java:273) ~[?:?]
--:--:-- 	at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:723) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52]
--:--:-- 	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]

...zur Frage

Eigenes Plugin Crash bitte Hilfe!?

Hey Ich habe heute mein Erstes Plugin mit java Programmiert und ich finde es toll,

ich wollte es ausprobieren aber die console zeigte andauernd diese Fehler Meldung :C bitte Hilfe :

[20:29:21 ERROR]: Could not load 'plugins/Heal.jar' in folder 'plugins'

org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml

at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:162) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:289) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.<init>(CraftServer.java:251) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.PlayerList.<init>(PlayerList.java:69) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedPlayerList.<init>(SourceFile:14) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:179) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]

Caused by: org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token

found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)

in 'reader', line 9, column 1:

...zur Frage

Was möchtest Du wissen?