Wieso funktioniert mein Apache2 Webserver nach Installation von Postfixadmin nicht mehr?

4 Antworten

Hallo

bist Du Jörg Rödiger und installierst du den Mailserver auf einem Root-Server beim Hoster? (Probeweise nach einem Tutorial) Oder hast du zum Testen erstmal ein Labornetz? Was gibt ein ping mc.bypvp.de aus? Hast Du für den Apache Webseiten erstellt oder liegt im DocumentRoot noch die Standard index.html (it works)? Sind die Ports offen?

Fragen über Fragen

Gruß

Der Ping liegt bei ca. 3 ms (der Server steht in meinem Netzwerk) Auch SSH, Minecraft und FTP funktionieren

0

Der Rechner ist bei mir im Netzwerk, im Webordner(/var/www/html/) liegt eine Wordpress Installation, alle benötigten Ports sind offen.

0

Hallo

als ich in Teil 3 bei 51:41 war

Ich will und werde mir nicht ansehen welche Videos das sind, deshalb teile mit bei welchem Schritt genau was passiert?

mc.bypvp.de/postfixadmin

lässt sich die Adresse denn vom entfernten Rechner aus anpingen?

Linuxhase

In diesem Abschnitt wird die Mailbox eingerichtet (nach langer Zeit wird das Terminal verlassen)

Ja, alle anderen Dienste ( SSH, Minecraft, FTP) funktionieren tadellos 

0
@Linux1234

@Linux1234

Nun besser?

Nein keineswegs, bitte einmal lesen: http://www.the-one-brack.org

Ja, alle anderen Dienste ( SSH, Minecraft, FTP) funktionieren tadellos 


Es kann doch nicht so schwer sein folgendes Kommando auszuführen:

ping -c5 mc.bypvp.de

oder auch:

safari bypvp.de/postfixadmin

Ich jedenfalls erhalte das:

ping -c5 mc.bypvp.de
PING carlos.anydns.info (93.200.200.224) 56(84) bytes of data.
64 bytes from p5DC8C8E0.dip0.t-ipconnect.de (93.200.200.224): icmp_seq=1 ttl=54 time=32.9 ms
64 bytes from p5DC8C8E0.dip0.t-ipconnect.de (93.200.200.224): icmp_seq=2 ttl=54 time=29.5 ms
64 bytes from p5DC8C8E0.dip0.t-ipconnect.de (93.200.200.224): icmp_seq=3 ttl=54 time=29.4 ms
64 bytes from p5DC8C8E0.dip0.t-ipconnect.de (93.200.200.224): icmp_seq=4 ttl=54 time=30.1 ms
64 bytes from p5DC8C8E0.dip0.t-ipconnect.de (93.200.200.224): icmp_seq=4 ttl=54 time=30.1 ms
--- carlos.anydns.info ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3001ms
rtt min/avg/max/mdev = 29.481/30.523/32.941/1.430 ms

Das bedeutet das Deine Subdomain erreichbar ist, nicht aber das auch Dein Postfix richtig arbeitet. Was der allerdings dieser mit Deinem Webserver zu tu  hat mußt Du noch erklären.

Zeig doch bitte auch mal:

ROUTER=$(traceroute google.de|head -2|tail -1|awk -F "(" '{print $2}'|awk -F ")" '{print $1}')
ping -c3 $ROUTER

Linuxhase

0
@Linuxhase

Hier:

root@carlosserver:/usr/local# ping -c3 $ROUTER
PING 192.168.178.1 (192.168.178.1) 56(84) bytes of data.
64 bytes from 192.168.178.1: icmp_seq=1 ttl=64 time=0.426 ms
64 bytes from 192.168.178.1: icmp_seq=2 ttl=64 time=0.410 ms
64 bytes from 192.168.178.1: icmp_seq=3 ttl=64 time=0.398 ms

--- 192.168.178.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 0.398/0.411/0.426/0.020 ms
root@carlosserver:/usr/local#
0
@Linux1234

@Linux1234

PING 192.168.178.1

schön ich weiß nun welche LAN-IP Dein Router hat und das der Server darüber erreichbar ist, was aber ist mit den beiden anderen Kommandos?

Wenn Dein Server bei Dir zuhause steht ist es das mindeste das er auch von jedem Rechner des gleichen Subnetzes erreichbar ist. Darüber hinaus muss der Server bypvp.de (93.200.211.212) aber auch erreichbar sein, einmal über seine IP-Adresse im WAN und natürlich auch über seinen Domainnamen, den Du ja bei anydns.info eingetragen hast.

Da Dein Server offensichtlich nur auf Ping-Anfragen reagiert, nicht aber auf den üblichen Ports lauscht, vermute ich eher das Deine Serverkonfiguration fehlerhaft ist (Jedenfalls eher als einen Fehler im Routing.

Du musst in Deinem Router schon explizit die benötigten Ports, in beide Richtungen, freischalten resp. eine Port-Weiterleitung für diese einrichten. Bei einem Web-Server wäre das Port 80 und beim E-Mail-Server: 24, 25, 110 oder 143, je nachdem welche Konfiguration und Sicherheitsstufe/Verschlüsselung Du gewählt hast.

Linuxhase

0

Nun, Nach weiteren versuchen, hat sich das Problem über Nacht von alleine gelöst :) Danke für eure Bemühungen :)

von alleine gelöst

Spontane Selbstheilung ist zwar unlogisch, aber wenn es für Dich gelöst ist - Viel Spaß!

0

Was sind LSB tags und overrides in Linux?

Ich versuche gerade meinen Raspberry zu instalieren. Hab eine Datei erzeugt mit folgendem Inhalt:

!/bin/bash /etc/init.d/tightvncserver

Carry out specific functions when asked to by the system

case "$1" in 

start) 

su pi -c '/usr/bin/vncserver -geometry 1440x900' 

echo "Starting VNC server " 

;; 

stop)

pkill vncserver 

echo "VNC Server has been stopped (didn't double check though)" ;; *)

echo "Usage: /etc/init.d/blah {start|stop}"

exit 1

;;

esac

exit 0

wenn ich das Kommando "sudo update-rc.d tightvncserver defaults" eingebe kommt immer die Meldung "insserv: warning: script 'tightvncserver' missing LSB tags and overrides"

Was muss ich ändern damit es funktioniert?

...zur Frage

Crontab Minecraft Server starten?

Ich möchte bei Linux über Crontab meinen Minecraft Server automatisch neustarten.

in crontab -e steht das drin aber es geht nicht:

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
0 0 * * * screen -S mc -X stuff 'say §cServer §cstartet §cin §c§n30 §cmin §cneu!\n'
10 0 * * * screen -S mc -X stuff 'say §cServer §cstartet §cin §c§n20 §cmin §cneu!\n'
20 0 * * * screen -S mc -X stuff 'say §cServer §cstartet §cin §c§n10 §cmin §cneu!\n'
25 0 * * * screen -S mc -X stuff 'say §cServer §cstartet §cin §c§n5 §cmin §cneu!\n'
29 0 * * * screen -S mc -X stuff 'say §cServer §cstartet §cin §c§n1 §cmin §cneu!\n'
30 0 * * * screen -S mc -X stuff 'stop\n'
31 0 * * * screen -S mc java -Xmx7168M -Xms7168M -jar forge-1.7.10-10.13.4.1614-1.7.10-universal.jar nogui

Was habe ich falsch gemacht? Also alles andere geht bis auf das starten selbst...

...zur Frage

meine www.domain leitet auf des webinterface von mailcow also mail.domain wie kann ich es beheben, das meine www.domain Domain auf den webserver leitet?

siehe Frage und ich nutze apache2 auf Debian.

danke für die antworten

...zur Frage

Apache configurations Fehler, wie kann ich diesen beheben?

Hi GuteFrage.net-Community(also Hallo an dich! :) ),

ich habe mir einen Apache2 Webserver mit php und libapache2-mod-php, danach MySQL (Server und Client) php-MySQL per apt-get installiert. Danach habe ich noch phpmyadmin installiert, aber es wurde nicht im Web angezeigt, also habe ich

echo Include /etc/init.d/apache2.conf >> (das >> soll eigentlich 2 Pfeile nach Links darstellen)  /etc/apache2/apache.conf

eingegeben, und den Webserver neugestartet, aber es kam ein Error heraus.

[failed!] Starting apache2 (via systemctl):
apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.

Dann hatte ich

systemctl status apache2.service 

eingegeben und folgendes kam heraus:

* apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
           `-apache2-systemd.conf
   Active: failed (Result: exit-code) since Sat 2017-05-27 09:49:58 UTC; 3min 2s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 19282 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 18233 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
  Process: 19902 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

May 27 09:49:58 Server apache2[19902]:  *
May 27 09:49:58 Server apache2[19902]:  * The apache2 configtest failed.
May 27 09:49:58 Server apache2[19902]: Output of config test was:
May 27 09:49:58 Server apache2[19902]: apache2: Syntax error on line 222 of /etc/apache2/apache2.conf: Could not open configuration file /etc/init.d/
May 27 09:49:58 Server apache2[19902]: Action 'configtest' failed.
May 27 09:49:58 Server apache2[19902]: The Apache error log may have more information.
May 27 09:49:58 Server systemd[1]: apache2.service: Control process exited, code=exited status=1
May 27 09:49:58 Server systemd[1]: Failed to start LSB: Apache2 web server.
May 27 09:49:58 Server systemd[1]: apache2.service: Unit entered failed state.
May 27 09:49:58 Server systemd[1]: apache2.service: Failed with result 'exit-code'.

,und dann hatte ich unte in der .conf Datei geschaut ob da auch wirklich die Datei angegeben ist weil in dem Error oben /etc/init.d/ stand.

/etc/init.d/apache.conf:

...
# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Include /etc/init.d/apache.conf   (der angegebene Error)

Was kann ich tuen, dass der Fehler behebt wird?

MFG ItzCrasher (P.S.: Diesen Text werde ich auch auf anderen Seiten posten.)

...zur Frage

Was möchtest Du wissen?