Wie wäre eine Formel um es in Excel anzuwenden und gibt es noch bessere anwendungen um das umzusetzen?

... komplette Frage anzeigen

3 Antworten

Das ist so schon machbar.

Die Formel für B1 ist dann

=INDEX(C$13:C$18;VERGLEICH($A1;B$13:B$18;0))

Diese Formel kannst du bis B10 runter kopieren. Für die Leute, die nicht in der Rangliste sind, wird NV! ausgegeben. Falls du stattdessen lieber eine leere Zelle haben möchtest, verwendest du

=WENNFEHLER(INDEX(C$13:C$18;VERGLEICH($A1;B$13:B$18;0));"")

Falls deine Tabellenstruktur so ist wie auf dem Bild, kannst du die Formel auch für die beiden anderen Bereiche nach rechts kopieren und in den nicht benötigten Spalten wieder löschen.

PS

Um das beispiel zu verstehen: A1-A10 sind die ränge

A1:A10 sind laut dem Bild die Nummern der Personen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von fz234
17.03.2016, 20:56

Vielen vielen dank!

A1-A10 war falsch, stimmt!

Wo wir gerade dabei sind, hast du mich mit "NV!" und "leer" auf eine idee gebracht, diese zeile mit dem "aktuellen platz, anhand der vorrunde" zu benennen. Das wäre richtig gut!

In zeig es an einem Bild:

http://www.bilder-upload.eu/show.php?file=8ec251-1458244875.jpg

F20 ist eine 8 weil er anhand der vorrunde den besten platz hatte ( platz 4 (B23)

I 28 ist eine 9 weil er anhand der vorrunde den fast schlechtesten platz hat (E28)

I25 muss nicht beachtet werden, da kann entweder "NV!" oder "leer" stehen.

Wenn es möglich ist dann kann die Formel mit in die andere hinein, sodass alle plätze in einer reihe sind(7,8,9), es kann aber auch so wie auf dem bild aussehen mit ein bisschen versatz!

lieben gruß! wäre nochmal ein netter zug wenn ich es vollständig hin bekomme!

0

Da der Support die andere Frage gelöscht hat, obwohl ich geantwortet hatte (freut mich immer sehr), pack ich es hier rein, um Dir zumindest mal eine Lösungsidee geben zu können. Gelöst war das Thema SVERWEIS um die aktuellen Rangfolge unterzubringen und das bei Nicht-Treffern nicht NV angezeigt wird. Wenn Ergebnisse aus einer vorherigen Rangfolge noch einfließen sollen, braucht es eigentlich nur eine Wenn-Bedingung

=WENNFEHLER(SVERWEIS($E5;H$18:I$20;2;FALSCH);WENN(F5<>"";WENN(F5<=3;F5+3;F5+2);""))

Wennfehler greift, falls in dem aktuellen Durchgang kein SVERWEIS Treffer gefunden wird. Dann wird geprüft ob eine Platzierung im vorherigen Durchgang vorliegt (also F5 nicht leer). In der anderen Frage hattest Du nur Platz 1-3 verwendet, daher ist die Prüfung nicht passend zu dieser Frage. Es geht um die Unterscheidung, ob die gefundene Zahl F5 aus einer Platzierung stammt (dann 1-3) oder nicht (also der Fall, dass F5 wiederum nur gefüllt ist, weil vorher eine Platzierung vorlag)

Antwort bewerten Vielen Dank für Deine Bewertung

Mein Sortierungsvorschlag (siehe Bild).

B2 =WENNFEHLER(INDEX($A$13:$A$22;VERGLEICH($A2;B$13:B$18;0));"")

(vergleiche mit DeeDee07)

C2 

=WENNFEHLER(INDEX($A$13:$A$22;VERGLEICH($A2;C$13:C$18;0));WENN(UND(ISTZAHL(B2)=WAHR;(ISTZAHL(INDEX($A$13:$A$22;VERGLEICH($A2;C$13:C$18;0))))=FALSCH);INDEX($A$13:$A$22;VERGLEICH($A2;B$13:B$18;0);0)+10;"ERFOLGLOS"))

(beide Formeln nach unten ziehen oder die von C2 eben auch zur Seite)

Ich glaube die Sortierung erklärt sich von alleine. Ich entschuldige mich für die Sendepause.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?