Wie verknüpft man verschiedene Werte in der "WENN;DANN;SONST"-Funktion in Excel miteinander?

...komplette Frage anzeigen

5 Antworten

Es gibt auch die WENN(UND(Argument1;Argument)) Funktion.Hier können mehrere Kriterien, die gleichzeitig zutreffen müssen abgefragt werden. Z.B. WENN(UND(A1=10;A2=20);"Richtig!";"Falsch!") würde den Eintrag "Richtig!" in der aktiven Zelle bewirken, wenn Zelle A1 den Wert 10 und Zelle A2 den Wert 20 enthält. Stimmt ein Zellenwert nicht, erfolgt der Eintrag "Falsch!". Alternativ gibt es noch die Kombination WENN(ODER(...! Hier muss nur eines der Kriterien erfüllt sein! Oder man arbeitet mit verschachtelten WENN-Abfragen. Da kann man viel mehr Argumente abfragen. Das geht für hier aber vielleicht zu weit.

Hallo,

es gibt auch noch eine besondere Form der WENN-DANN-SONST-Verwendung. Man addiert die einzelnen Abfragen einfach.

Hier ein Beispiel (Die Spalte A ist zu prüfen):

=WENN(A1>0;1;0)+WENN(A1>5;2;0)+WENN(A1>10;3;0)+WENN(A1>30;4;0)

Durch die DANN-Alternative "0" wird bleiben unzutreffende Bedingungen unberücksichtigt. Bei A1 = 1 erscheint 1, bei 6 steht 2 da und bei 500 gibt die Funktion 4 zurück.

So kann man WENN-Verknüpfungen praktisch unendlich schachteln.

Durch die DANN-Alternative "0" wird bleiben unzutreffende Bedingungen unberücksichtigt. Bei A1 = 1 erscheint 1, bei 6 steht 2 da und bei 500 gibt die Funktion 4 zurück

nein bei 500 gibt die Funktion korrekterweise 10 zurück da hier alle Bedingungen wahr sind und somit 1+2+3+4 gerechnet wird.

0

Das geht ählich wie bei deiner vorigen Frage. Du mußt nur die Funktion schachteln. Das geht bis zu 7 mal. Also statt des "Dann"-Gliedes eine erneute "Wenn"-Abfrage.

=WENN(A1="a";WENN(B1="b";"ok";"falsch");"falsch")

Bei solchen (und anderen Problemen) versuche ich schon mal http://www.ityco.com, eine Seite, die auch von den Übungsschulen frequentiert wird.

Was möchtest Du wissen?