Wie verknüpfe ich zwei wenn-und Funktionen in Excel?

... komplette Frage anzeigen

3 Antworten

Ersetze UND durch ODER, bzw. wenn du zwei solcher Formeln, wie von dir genannt ODER-verküpfen willst:

=WENN(ODER(UND(...);UND(...));"RICHTIG";"FALSCH")

Wenn du statt "RICHTIG" auch WAHR akzeptieren würdest, hättest du es noch einfacher. Dann könntest du dein Statement reduzieren:

=ODER(UND(...);UND(...))

Antwort bewerten Vielen Dank für Deine Bewertung

Dein Zweck lässt sich vllt auch ganz anders erreichen, probier mal:

=WAHL((AD14="richtig")+(AE14="richtig")+1;"beidefalsch";"einsrichtig";"beiderichtig")

sehe grade Suboptimierers AW, auch hier gilt, wenn Boolsches WAHR anstatt "richtig":

=WAHL(AD14+AE14+1;"beidefalsch";"einesrichtig";"beiderichtig")

Man könnte mit entsprechenden Faktoren und logarithm. Auswertung  sogar noch zwischen den beiden richtig/falsch-Fällen differenzieren, aber das erspare ich mir (und Dir) jetzt.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
18.07.2016, 22:45

Da es gar nicht so aufwändig ist, doch noch die Formel, die zwischen links und rechts differenziert:

=WAHL(D20*2^0+E20*2^1+1;"beide falsch";"links richtig";"rechts richtig";"beide richtig")

So kurz kriegst Du das mit keiner Wenn-dann-Formel hin!

0

Wenn(Bedingung 1 ; Wenn(Bedingung2; Fall "beide erfüllt"; "nur Bed 1 erfüllt); "Fall Keine erfüllt")

LG

einfach die 2. When in die Dann oder SOINST Bedingung reinlegen

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?