Wie rechnet man das in Excel?

... komplette Frage anzeigen

3 Antworten

Heißt das, dass bis 50€ immer 5€ abgezogen werden, zwischen 50 und 100 aber 10% und dann über 100 wieder 10€.
Wenn das nicht weiter geht, würde ich das gar nicht über eine extra Liste und Sverweis lösen, denn einmal addieren und dann wieder multiplizieren bekommst Du so nicht hin.
Da schreibst Du es besser direkt in die Formel, meinetwegen auch mithilfe der Liste, wenn die Werte sich oft ändern. Formel in B3 und runterkopieren also entweder:

=WENN(C3="R";WENN(A3>100;A3-10;WENN(A3>50;A3*0,9;A3-5));A3)

oder per Liste:

=WENN(C3="R";WENN(A3>$F$6;A3-$G$6;WENN(A3>$F$5;A3*(1-$G$5);A3-$G$4));A3)

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von sebastianmias1
13.07.2017, 00:52

Vielen Dank auch dir,

Ja es hat geklappt ! :))

1

Als Alternative zu den beiden anderen richtigen Lösungen:

=A3-(C3="R")*MIN(10;(MAX(5;A3*0,1)))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
13.07.2017, 14:31

DH!

Sehr raffinierte Lösung.
Da bin ich wohl nicht der Einzige der gerne mit MIN/MAX und Wahrheitswerten spielt.
SO was gefällt mir immer besonders.

0

=WENN(C3="R";A3-A3*SVERWEIS(A3;F4:G6;2;WAHR))


Ist das nicht die Formel für B3, bzw. war die davor nicht falsch? :)

LG

____________________

ist auch nicht richtig, da A4-A4*Sverweis keinen Sinn bei ---5 und -10€ ergibt, ich reich dir gleich meinen verbesserten Vorschlag nach. :)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von sebastianmias1
12.07.2017, 22:18

Vielen Dank,!

Das Problem ist, dass es sich in der Liste um eine Mischung aus Dezimalzahlen handelt.Excel zieht ein´fach immer 0,1 ab anstatt, dass er 10 Prozent von A3 abzieht. Wenn ich jetzt A3-A3* hinschreibe, stimmen ja die Abzugswerte der Dezimal zahlen nicht,

z.b. Kosten von 10 Euro werden dann gerrechnet:

10-10*5€, was ja nicht stimmen würde, da ich ja einfach 10 € -5€haben will.

---------------

Danke ! :)

0
Kommentar von sebastianmias1
12.07.2017, 22:35

Vielen Dank thewalkingsushi,

Du warst eine große Hilfe, das mit dem r hab ich sogar selbst hingekriegt xD .

Vielen Vielen Dank !!

0

Was möchtest Du wissen?