Wie muss die Excel Formel aussehen?

...komplette Frage anzeigen

4 Antworten

Das kannst du mit dem SVERWEIS lösen. Wird nicht genau der passende Wert gefunden, wird der nächsthöhere (oder -niedrigere [weiß ich gerade nicht]) genommen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Lollo90
18.05.2017, 10:24

Muss ich dann dazu in der Matrix für jede mögliche Abnahmemenge vorher den Gesamtpreis selbst berechnen?

0

=WENN(Abnahme>=51;20*15+30*12+(Abnahme-50)*10;WENN(Abnahme>=21;20*15+Abnahme-20)*10;Abnahme*15))

Konnte die Formel leider noch nicht testen, müsste aber funktionieren.

Bei weiteren Fragen stehe ich dir gerne zur Verfügung.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Lollo90
18.05.2017, 10:30

Funktioniert leider nicht :(
"Sie haben zu viele Argumente für diese Funktion eingegeben"
Soweit ich das verstehe, steht der letzte Teil, also "Abnahme*15" schon "außerhalb" der Formel

0

Es fehlt vor ABNAHME-20) eine (

Antwort bewerten Vielen Dank für Deine Bewertung

So geht's auch:

=(MAX(B1-50;0))*10+(MAX(MIN(50;B1);20)-20)*12+(MIN(20;B1))*15

Gruß

Hannes

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?