Wie mach ich eine WENN FUNKTION zur meiner unten stehenden Bedingung?

...komplette Frage anzeigen

2 Antworten

Sollen denn bei Duplikaten alle mit "1" markiert werden oder jeweils nur das Doppel?

Dann würde ich die Liste alphabetisch sortieren. In die Spalte daneben würde ich dann die Formel schreiben: =wenn(A2=A1;"1";"")

Diese dann bis nach unten durchziehen. Dann bekommen alle Duplikate eine 1, während die "Originale" ohne Markierung bleiben.

Mit kopieren Werte einfügen kann man dann die Einsen fixieren und nach dieser Spalte die Duplikate aussortieren.

Wenn das Ziel ist, lediglich die Doppelten zu entfernen, dann gibts dafür die Excel-Funktionion "Duplikate entfernen".

Wenn die Doppelten markiert werden sollen, geht das auch ohne "wenn-Funktion". Da reicht dann "zählenwenn" und dann sortieren nach Wert.

Ne ich bräuchte des so wie ich geschrieben hab. Gibt es dafür dann überhaupt eine Funktion? Danke schon mal!

0
@170298

Es geht schon auch mit WENN.

=wenn (zählenwenn(Bereich;A2;">1");1;"")

2
@JustNature

     A 

1. Maier =WENN(ZÄHLENWENN(Bereich(A1;">1";1;))

2. Sepp

3. Huber

4. Maier

5. Franz 

6. Franz 

7. Günther

????????????????????????

0
@170298

Meine Antwort war nicht für Excel-Einsteiger gedacht. Ich habe hierbei schon Grundkenntnisse vorausgesetzt.

Mit Bereich ist gemeint, daß mit $-Zeichen eine Spalte definiert wird, z.B. $A2:$A2000, wenn die Daten in Spalte A sind, beginnend bei Zeile 2. Die Formel steht dann in B2.

Sie ist danach in alle Zellen, v.B. von B2 bis B2000 zu kopieren.

Danach kann noch nach Spalte B sortiert werden.

2
@JustNature

noch kürzer gehts mit (i'wo in der ersten Zeile)

=Zählenwenn($A:$A;A1)-1

nach unten kopieren ("runterziehen").

Dabei wird sowohl das erste Auftreten wie auch das zweite mit 1 markiert, einfach auftretende mit 0. Diese Info ist häufig nicht hilfreich

Willst Du bei einem Eintrag wissen, WO der nächste (2++.) Eintrag steht, dann:

=Vergleich($A1;A1:$A$2000;0)

Da das aber für einzelEinträge Fehler liefert, was stört, so einbetten:

=wennfehler(Vergleich($A1;A1:$A$2000;0);"ok")

0

Was möchtest Du wissen?