Wie lautet die Excel funktion die ich suche (siehe Details?

...komplette Frage anzeigen Erklärung - (Computer, Software, programmieren)

2 Antworten

ich dachte schon, dass ist eine Testfrage, um zu schauen, wer die Herausforderung annimmt, denn das ist zum einen ja eine Kreuztabelle, die aber transponiert werden muss weil Zeilen / Spalten sich vertauschen, zum anderen mehrere Treffer möglich sind. Mehrere Treffer in eine Zeile bekomme ich nicht hin, ohne mir die Finger zu brechen

Es sind also zwei verschiedene Formeln, um den ersten Treffer in der oberen Zeile einer Zeiteinheit zu ermitteln und in der darunterliegenden dann einen möglichen zweiten Treffer. Über optische Mittel kannst Du dafür sorgen, dass die beiden Zeilen als zusammengehörig erkannt werden. Vielleicht ist es für weitere Auswertungen auch sinnvoll die Werte nicht in eine Zeile zu vermischen (aus der Not eine Tugend machen ;-)

Ich frage in den Formeln nicht direkt auf die Zeiteinheiten 1,2,3 oder ähnliches ab, sondern habe es mit bereich.verschieben umgesetzt, damit man die Formeln in die anderen Zeilen kopieren kann und dadurch automatisch die Spalte, in der zu suchen ist, geändert wird. Das funktioniert aber nur solange immer zwei Zeilen zu einer Zeit gehören und keine Lücken enthalten sind: weder bei den Spalten in der Ursprungstabelle, noch in der Zieltabelle.
Das "aufrunden(zeile...." bewirkt, das jeweils nach zwei Zeilen die Suchspalte um 1 nach rechts verschoben wird. Daher ist egal, ob die Zeiteinheiten in den beiden Tabellen gleich oder unterschiedlich beschriftet sind.

In der Formel für die möglichen zweiten Treffer muss der Bereich zusätzlich "nach unten" verschoben werden, damit der erste Treffer nicht mehr im Bereich enthalten ist. Das müsste theoretisch auch in einer Zeile gehen, also die beiden Formeln einfach verknüpfen, das habe ich aber nicht hinbekommen.

Excel zeigt mir teilweise an, dass die Formel fehlerhaft ist - ich kann aber nicht erkennen, was noch schief sein sollte, in meinen Tests funktioniert es zumindest.

Formel für die jeweils erste Zeile:

=WENNFEHLER(INDEX($A$2:$A$7;VERGLEICH(I$6;BEREICH.VERSCHIEBEN($C$2:$C$7;0;AUFRUNDEN(ZEILE(E1)/2;0)-1);0);1);"")

für die jeweils zweite Zeile:

=WENNFEHLER(INDEX(BEREICH.VERSCHIEBEN($A$2:$A$7;VERGLEICH(I7;$A$2:$A$7;0);0);VERGLEICH(I$6;BEREICH.VERSCHIEBEN($C$2:$C$7;VERGLEICH(I7;$A$2:$A$7;0);AUFRUNDEN(ZEILE(E2)/2;0)-1);0);1);"")
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaliKalo
18.08.2016, 19:18

Bei den Zellen, die am Ende nur einen Namen enthalten, funktioniert es nun nach ein wenig rumgeschiebe. Allerdings bei Überschneidungen bekomme ich Fehler. Aber, dass ist schon 1000x besser als die manuelle Tortur.

Danke für die schnelle und präzise Hilfe

0
Kommentar von Iamiam
18.08.2016, 22:02

ein dickes DH!

Das Verknüpfen kann entweder passieren, indem Du einfach inkauf nimmst, dass der gleiche Name 2x erscheint oder mit bei dieser Lösung äusserst aufwändigen Wiederholungen:

=FormelName1&Wenn(Formelame1=FormelName2;"";", "&FormelName2)

0

Nach längerem Nachdenken ahne ich, was Du darstellen willst. Die Schwierigkeit ist der zweifache Einsatz. Kann es auch noch höhere Kumulierungen geben (dreifach oder sogar noch höher und wenn ja, wie hoch maximal?)

Soll in der 2. Tabelle K in B1 und die 1 in A2 stehen?. Schreib mal die wichtigsten Grenzadressen auf, im derart Allgemeinen kann man nur schwafeln!

Und nochmal zum Verständnis: K ist eine Person oder ein Gerät, 1:5 waagrecht ist ein Zeitraum, zB jeweils ein Wochentag und entspricht 1:5 senkrecht aber mit Zwischenzeile, A:F sind Einsatzorte

Muss das ohnehin erst verinnerlichen und werds jetzt erst mal überschlafen, hoffe morgen Deine AW vorzufinden!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von KaliKalo
18.08.2016, 10:04

K, LF, G, oder T sind Orte.

A-F sind Personen

1-5 sind Zeiträume.

In der Matrix ist einer Person und einem Zeitpunkt je ein Ort zugeordnet.

In der Tabelle soll am Ende einem Zeitpunkt und einem Ort eine Person zugeprdnet werden.

Das Resultat soll letztendlich die lesbarkeit erhöhen.

Mein Problem ist, dass ich nur diese Matrizen bekomme und diese als Plan nicht so gut geeignet sind wie eine Tabelle in der Form wie sie rechts zu finden ist.

0

Was möchtest Du wissen?