Wie lautet die Excel-Formel (wenn, und, oder)?

3 Antworten

In Deiner Formel fehlt nur ein Semikolon:

=WENN(UND(ODER(Sterne=5;Kinderfreundlich="JA";Nichtraucherzimmer="JA");Sterne=4;Seminarräume="JA";Restaurant="JA");"EMPFEHLUNG";" ")

Aber diese Formel passt nicht ganz, denke ich.

Aufgabe: Alle 5-Sterne-Hotels bis zum Preis von € 200, die kinderfreundlich sind oder Nichtraucherzimmer haben. Außerdem alle 4-Sterne-Hotels mit Seminarraum und Restaurant. Wenn die dass haben muss da Empfehlung stehen, wenn nicht, dann nichts.

Das würde so klappen:

=WENN(ODER(UND(Sterne=5;Preis<=200;ODER(Kinderfreundlich="JA";Nichtraucherzimmer="JA"));UND(Sterne=4;Seminarräume="JA";Restaurant="JA"));"EMPFEHLUNG";"")

Teste aber mal ausführlich.

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Da es "Alle Hotels" heisst, nehme ich an, da steht eine Liste. Dann funktioniert das mit Sterne, Kinderfreundlich etc nicht: xl sucht da nämlich nach einer benannten Zelle "Sterne", einer anderen "Kinderfreundlich" etc

Wahrscheinlich hast du da Spalten stehen mit der Überschrift "Preis", "Sterne"... aber wo stehen die und was ist da eingetragen? **** oder 4?

Beispiel (Spalte A, dann B usw):

  • A: Hotelname; B:irrelevant; C:Preis; D:Sterne; E:Kinderfreundlich
  • Ambassador; genaue Adresse; 199,50; 5; Ja; --weitere analog--

Formel in der Zeile2=Ambassador (irgendwo rechts, zB in Spalte Empfehlung)

=WENN(UND($C2<=200;ODER($D2>=4;$E2="Ja"));"Empfehlung";"nix gutt")

weitere Oderargumente innerhalb der Oderklammer anhängen, also $F2=...;G2=...

Sind die Sterne dagegen als ***** angegeben, wirds noch komplizierter: Entweder

...;Nicht(istfehler(Suchen("****";$D2;1)));... oder

...;(Länge($D2)-Länge(Wechseln($D2;"*";""))>=4;...

Versuchs mal!

Was möchtest Du wissen?