Wie lautet die Excel formel? Möchte rechts auf der Tabelle alle Rechnungsnummern der CC-Fälle aufgelistet haben?

...komplette Frage anzeigen EXCEL - (Excel, WENN DANN SVERWEIS)

3 Antworten

Dummerweise zeigst Du keine Spalte-/ Zeilenköpfe.
Ich nehme einfach mal an "Rechnung" steht in B4, dann diese Formel in E5 und runterkopieren:

{=WENNFEHLER(INDEX($B$1:$B$1000;KKLEINSTE(WENN($C$5:$C$1000="CC";ZEILE($C$5:$C$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Bereiche musst Du natürlich anpassen.
Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
nurXXX 18.11.2016, 11:27

nein leider nicht :(

0
Oubyi 18.11.2016, 13:10
@nurXXX

Tja, da wirst Du leider nicht drumherum kommen zu erklären, was leider nicht klappt.
Das mindeste, was ich erwartet habe ist, dass Du die Zelladressen verrätst und Deine angepasste Formel zeigst.
SO ist Dir leider nicht zu helfen.

0
Oubyi 23.11.2016, 14:01

Danke fürs

0

Am einfachsten ist es, einen Filter zu setzen und die gefilterten Werte zu kopieren.

Es geht aber auch mittels Matrixformel. Dazu benötigst du KKLEINSTE, ZEILE und WENN, wenn ich mich nicht irre. 

Antwort bewerten Vielen Dank für Deine Bewertung
=WENN(Bn = "CC"; An; "")

Wobei A, B = Spalte, n = Zeilennummer


Antwort bewerten Vielen Dank für Deine Bewertung
nurXXX 17.11.2016, 13:45

könntest du mir die formel genauer aufschreiben

mit zahlen anhand meiner tabelle

0
Herb3472 17.11.2016, 13:49
@nurXXX

Du hattest in deinem Beispiel keine Spalten und Zeilen angegeben, aber ok:

D1 [=WENN(B1 = "CC"; "A1;"")]

D2 [=WENN(B2 = "CC"; "A2;"")]

D3 [=WENN(B3 = "CC"; "A3;"")]

In eckiger Klammer steht jeweils die Formel der Zellen D1 bis Dn

0
Herb3472 17.11.2016, 13:54
@Herb3472

Sorry, da hat sich ein Fehler eingeschlichen, Zellenname A natürlich ohne Anführungszeichen:

Korrekt lautet die Formel:

D1 [=WENN(B1 = "CC"; A1;"")]

D2 [=WENN(B2 = "CC"; A2;"")]

D3 [=WENN(B3 = "CC"; A3;"")]

0
nurXXX 17.11.2016, 14:27
@Herb3472

es handelt sich um mehrere zellen bis zu 800

als Beispiel hatte ich ihnen dur 4/5 genannt.

 

daher denke ich dass die formel nicht so sinvoll ist :)

aber trotzdem danke

0
Herb3472 17.11.2016, 15:21
@nurXXX

Wenn Du keine Matrixformel verwenden willst (Siehe weiter oben Antwort von Oubyi), musst Du die Formel in jede Ergebniszeile kopieren. Du trägst die Formel in die oberste Zelle ein und kopierst dann die Zellen soweit nach unten wie erforderlich, indem Du die Zelle mit der Formel  an der rechten unteren Ecke "anfasst" und markierst, und dann mit gedrückter Maustaste die Markierung nach unten ziehst

0

Was möchtest Du wissen?