Wie lautet die Excel-Formel für das Beispiel?

... komplette Frage anzeigen

2 Antworten

Kommt drauf an, was gegeben ist.

Wenn die Kundennamen in den Spalten B und E immer vorgegeben sind, Formel für Zelle F2 z. B.:

=WENN(BEREICH.VERSCHIEBEN($B$1;VERGLEICH($E2;$B:$B;0)+SPALTE()-SPALTE($F2)-1;0)=$E2;BEREICH.VERSCHIEBEN($C$1;VERGLEICH($E2;$B:$B;0)+SPALTE()-SPALTE($F2)-1;0);"")

Diese Formel in den Bereich F2:L4 kopieren (oder noch weiter nach rechts)

Wenn Spalte E aus Spalte B berechnet werden soll, wird es westenlich schwieriger, besonders ohne Matrixformel.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von PWolff
09.08.2017, 14:24

Wenn die Kundennamen immer blockweise untereinander stehen - also nicht gemischt, z. B.

Kunde 1
Kunde 1
Kunde 2
Kunde 1
...

kann in E3 die Formel stehen

=BEREICH.VERSCHIEBEN($B$1;VERGLEICH($E2;$B:$B;0)+ZÄHLENWENN($B:$B;$E2);0)

Diese Formel kann in Zeile E weiter heruntergezogen werden.

Dann sollte die Formel in F2 modifiziert werden:

=WENN(ISTNV(VERGLEICH($E2;$B:$B;0));"";WENN(BEREICH.VERSCHIEBEN($B$1;VERGLEICH($E2;$B:$B;0)+SPALTE()-SPALTE($F2)-1;0)<>$E2;"";BEREICH.VERSCHIEBEN($C$1;VERGLEICH($E2;$B:$B;0)+SPALTE()-SPALTE($F2)-1;0)))

(und es sollte in der Antwort "wesentlich" statt "westentlich" heißen)

2
Kommentar von augsburgchris
09.08.2017, 14:29

Perfekt. Auf Bereich.Verschieben bin ich ja gar nicht gekommen. Danke.

0

Ohne Matrixformel habe ich es leider nicht hinbekommen. Vielleicht hilft dir diese aber schon einmal weiter, einen matrixlosen Ansatz zu finden:

=WENNFEHLER(INDEX($C:$C;KKLEINSTE(WENN($B$2:$B$13=$E2;ZEILE($B$2:$B$13)*($B$2:$B$13=$E2);9^9);SPALTE(A$1)));"")

In F2 eingeben, mit Strg + Shift + Enter abschließen, dann am Kopierkreuz ziehen.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?