Wie kann nach einem Zellwert gesucht werden, damit ein anderer ausgegeben werden kann?

... komplette Frage anzeigen

1 Antwort

Es ist immer ganz gut, wenn du die Formel dazu schreibst, die du versuchst hast. Meist nur eine Klammer oder ähnliches. 

Das Ergebnis soll in d2 stehen, also gehört da die Formel hin. 

=sverweis(a2;b2:c4;2;falsch) 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von OlsenEgon74
07.03.2016, 08:48

Entschuldige, hätte ich selbst daran denken können...

Mein jetztiger Ansatzpunkt ist:

=INDEX(C$2:C$4;FINDEN(B$2:B$4;A2;2)>0;0)

allerdings komme ich gar nicht damit klar. Muss aber dazu sagen, dass ich kein Excel-Brain bin... Daher tu ich mich mit den Formeln sehr schwer...

Folgende Situation:

In Spalte A stehen Artikelbeschreibung mit div. Abkürzungen. Unteranderem gibt es Artikel die die Abkürzung

  • verz.
  • verchr. oder
  • verg.

beinhalten.

Ich möchte, dass in Spalte D das "Klarwort" ausgegeben wird. Eigentlich dachte ich an einen SVERWEIS, aber sobald sich noch anderer Text außer der Abkürzung in der Zelle befinden funktioniert dies nicht mehr... Mein SVERWEIS war dieser:

=SVERWEIS(A2;B2:C7;2;0)

Kann ich dem SVERWEIS beibringen, dass er diese Wortgruppe suchen soll?

Danke!

0
Kommentar von OlsenEgon74
07.03.2016, 09:04

Habe diesen Ansatz gerade noch probiert, der aber auch nur funktioniert wenn sich nur die Abkürzungsform in der Zelle befindet. Sobald die Abkürzung mit einem "." abgeschlossen wird oder noch andere Wörter in der Zelle stehen, werden keine Werte mehr ausgegeben...

=WENN(ISTFEHLER(VERGLEICH(B2;$A$1:$A$100;0));"";C2)

0

Was möchtest Du wissen?