Wie kann ich mit einer Excel-Funktion Teil einer Zelle ermitteln?

... komplette Frage anzeigen

2 Antworten

=TEIL(A1;FINDEN("_";WECHSELN(A1;"\\";"_";LÄNGE(A1)-LÄNGE(WECHSELN(A1;"\\";""))))+1;200)

So sollte es gehen

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von iMPerFekTioN
30.11.2016, 16:10

Wow Sehr schöne Formel! DH!

Willst du mir die erklären? Ich komm nicht mit =)

0

Hallo,

angenommen dein Pfad steht in A1, dann machst du dir in B1 eine kleine Hilfszelle mit dieser Formel:

{=VERGLEICH("\\";LINKS(RECHTS(A1;SPALTE(1:1));1);0)}

Matrixformel! Die"{}" NICHT mit eingeben, sondern die Funktion mit STRG+SHIFT+Eingabe abschließen!

Dann kannst du in C1 die Funktion

=RECHTS(A1;B1)

nutzen und bekommst das ausgegeben was du möchtest =)

Liebe Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
30.11.2016, 17:07

sehr schön, aber kleine Korrektur: Links und rechts vertauschen! (Und noch -1 rein)

Und warum Hilfszelle? Es geht bei mir (xl2010) auch so:

{=Rechts(A1;Vergleich("\";Links(Rechts(A1;Spalte(1:1));1);0)-1)}

Meine etwas ausführlichere Erklärung zur Wechseln-Formel s.dort.

1
Kommentar von iMPerFekTioN
30.11.2016, 17:29

Danke:) stimmt, du hast recht! Man kann die Funktionen auch einfach verknüpfen:p Danke dir und DH!

0

Was möchtest Du wissen?