Wie kann ich mir die einzelnen Tage(1,2,3....) von Monat x ausgeben lassen?

...komplette Frage anzeigen

4 Antworten

Wenn in A Zeile1 das Jahr und in A Zeile 2 der Monat steht, dann in A11:

  • =WENNFEHLER((SPALTE()&"."&$A2&"."&$A1)*1;"-")
  • wichtig: $ vor Spalten Jahr und Monat
  • *1 , damit nicht zu Datum umwandelbarer String als Fehler erkannt wird

nach rechts kopieren bis AE.

  • In Jahr darf sowohl 2017 wie auch nur 17 stehen, egal ob als Zahl oder als Label,
  • in Monat auch der abgekürzte oder der volle Monatsname, ebenfalls egal ob als Zahl 3 oder als Label '03. (aber alles ohne Punkt!). sogar Mrz wird wie Mär behandelt und akzeptiert, im Feb auch Febr, Febru, Februa !
  • Das dargestellte Format wird davon nicht beeinflusst (das ist nur durch das Zellformat in der Datums-Ergebnis-Zelle gesteuert)
  • Wenn das in höheren Spalten stehen soll, dann Spalte()-2 (Sp.C ist dann der Erste

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn Zelle mit Monat z. B. A1 ist und das Jahr in A2, dann A11 mit folgendem Inhalt nach rechts kopieren:

=WENN(SPALTE()<=TAG(DATUM($B$1;$A$1+1;1)-1);SPALTE();"")
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
02.03.2017, 15:03

Ich hatte Deine Antwort nur überflogen.
Habe sie jetzt ausprobiert und es klappt wohl, BIS AUF den Februar. Da wird der 29. für 2017 mit angezeigt.
Habe mich noch nicht weiter in Deine Formel vertieft, muss zur Arbeit.

0
Kommentar von domaei
02.03.2017, 19:02

Woow, vielen Dank für eure schnelle Hilfe. Hat super funktioniert!

Ich habe nun unter meiner Zeile 11 mit den Tagen eine weitere Zeile 12 und 13. Ist es möglich in diese die Zahl 1 einzufügen wenn aktuelles Datum -1 bzw. sofern ich nicht händisch 2,3 oder 4 in Zeile 13 einfüge?

Mein Gedanke ist der, das der Vortag (sofern kein WE oder Feiertag) automatisch grün und 1 drinnen steht, außer wenn ich manuell 2,3,4 in die Zeile 13 schreibe, dann soll eine bedingte Formatierung diese Felder färben (2=gelb, 3=rot, 4=blau).

Ich weiß ich bin da bei weitem über meinen Excel-Kenntnissen. Sorry für diese anspruchsvolle Aufgabenstellung.

Vielen Dank im Voraus.

0

Schreib in A1 z.B. Januar. In A2 das Jahr z.B. 2016 (War ein Schaltjahr)

In A3

=WENN(MONAT(DATUM($A$2;SPALTE();ZEILE()-2))=SPALTE();DA

Diese Zelle ziehst du bis A33. Jetzt markierst du die Zellen A1 bis A33 und ziehst die nach B1 bis B33 Und siehe da, der  Monat ist nur noch 29 Tage lang. Jetzt hat sich aber das Jahr nach 2017 geändert. Ändere dieses Jahr in 2016. Nun markier A1 bis B33 und zieh es bis L33. Nun hast du alle Monate für 2016 von Januar 2016 bis Dezember 2016. Für das nächste Jahr brauchst du nur in A2 das  nächste  Jahr eingeben. Jetzt passt aber die Jahreszahlen in den folgende Monate  nicht. Alle ändern.

Kalender - (Excel, Office, Formel)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von dkilli
02.03.2017, 16:57

Funktioniert auch unter LibreOffice. Ist kostenlos und gibt es auch als Portable Version! Kann genauso viel wie Excel 2016 bis auf kleine Unterschiede!!!

0

So habe ich es verstanden. Ist "mit der heißen Nadel gestrickt", also teste mal genau (Monat in A1, Jahr in A2).

=WENN(MONAT(DATUM($A$2;$A$1;SPALTE(A1)))=$A$1;DATUM($A$2;$A$1;SPALTE(A1));"")

Und nach rechts kopieren.
Geht vlt. auch einfacher!?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
02.03.2017, 15:01

Falls Du nur den Tag habe willst, entweder die Zellen so formatieren, oder:

=TAG(WENN(MONAT(DATUM($A$2;$A$1;SPALTE(A1)))=$A$1;DATUM($A$2;$A$1;SPALTE(A1));""))

0

Was möchtest Du wissen?