Wie kann ich in Excel Zellen ueberpruefen und ggf. uebernehmen, leere Zellen dabei jedoch ueberspringen?

... komplette Frage anzeigen

4 Antworten

Probier mal für D1:

=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(B:B;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1))))

und als Matrixformel abschließen mit Strg+Shift+Enter. Diese Formel in Spalte D runterkopieren.

(adaptiert von http://excelformeln.de/formeln.html?welcher=43 )

Solltest du mehr als 1000 Zeilen haben, dann die Formel entsprechend anpassen.

Falls du keine formelbasierte Lösung möchtest, kannst du Spalte A nach x filtern, dann Spalte B kopieren, Filter aufheben und in D einfügen.

Antwort bewerten Vielen Dank für Deine Bewertung

Setz einen Autofilter und filtere in Spalte A nach x. Dann kopierst du den gefilterten Block nach D oder arbeitest direkt mit der gefilterten Liste.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
16.08.2016, 16:16

Was auch geht:

=WENNFEHLER(INDEX($B$1:$B$3;KKLEINSTE(($A$1:$A$3="x")*(ZEILE($A$1:$A$3));ZEILE(A2)));"")

Und herunter ziehen

0

In C1:
=VERGLEICH("x";INDIREKT("A1:A100");0)

In C2:
=VERGLEICH("x";INDIREKT("A"&C1+1&":A100");0)+C1

In D1:
=WENN(ISTZAHL(C1);INDIREKT("B"&C1);"")

Die Formel in C2 nach unten ziehen und die Formel in D1 nach unten ziehen. (Das A100 in den C-Formeln anpassen, falls du mehr als 100 Zeilen hast)

Spalte C bei Bedarf ausblenden.

Alternativ hätte ich das Sortieren nach Spalte A vorgeschlagen.


Antwort bewerten Vielen Dank für Deine Bewertung

Was soll denn in Spalte D stehen, wenn A=2 ist?

Vielleicht schreibst du mal eine Tabelle, die so aussieht, wie du es dir wünschst.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von rotespuenktchen
16.08.2016, 15:38

Ich habe mein Beispiel etwas angepasst, sollte nun verstädlicher sein. 

0

Was möchtest Du wissen?