Wie kann ich in Excel Zeit berechnen 20:30 - 1:30?

... komplette Frage anzeigen

6 Antworten

Ich versteh leider gar nicht was hier wirklich das Problem ist...

Du schreibst in Zelle A1 20:30:00 und in Zelle A2 01:30:00

In B1 schreibst du jetzt =A2-A1 und hast dein Ergebnis von 04:00:00

Liebe Grüße,


iMPerFekTioN

P.s. wenn es dir wichtig ist, dass dein Format bei 20.30bleibt und nicht auf 20:30 steht, musst du nur ein Benutzerdefiniertes Format auf HH.MM setzen.

Zelle -> Rechtsklick -> Zelle Formatieren -> HH.MM

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
26.10.2016, 13:16

eben nicht! ="1:30"-"20:30" gibt nicht 4:00 (dezimal 0,20833..), sondern -0,79166.., als negative Zeit auch nur im 1904-System darstellbar, aber ohnehin falsch.

Nur unter umständlicher Einbeziehung des Datums wirds richtig!

4

Ich gehe mal davon aus das in Zeile 1 deine Überschriften sind und in Zeile 2 in A2 (20:30) und in B2 (01:30), dann nimm mal diese Formel:

=REST(B2-A2;1)

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
26.10.2016, 11:46

auch für Zeiterfassung insbes. bei Nachtschichten, aber auch sonst., bis knapp 24 Stunden. Immer

=Rest(Ende-Anfang als nur Uhrzeit, Format 0:00; die 1 ist die Einheit Tag)

Um die Formel zu verstehen, müsstest Du das Verhalten von Rest bei positiven und bei negativen Zahlen nachvollziehen. Kannst die Formel aber auch einfach nur anwenden.

3

Hallo,

in folgender Abbildung ist ein Beispiel, wie die Nachschicht und die Tagschicht am besten, in Heximal (realer Uhrzeit), berrechnet werden kann.

Gruß Tron

Antwort bewerten Vielen Dank für Deine Bewertung

In A3 steht Kommt, in B3  Geht, in C3 Pause . In D3 soll die Arbeitszeit stehen und E3 Zeit in Minuten. In D3 folgende Formel:

=WENN(B3>=A3;B3-A3-C3;1+(B3-A3-C3))

In E3 

=D3*24*60

Siehe Bild

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
26.10.2016, 11:52

@ dkilli: s. m. Kommentar zur AW Schmiddi!

1

Es ist doch immer immer wieder traurig das Fragesteller auf Fragen keine Antwort geben. Viele geben sich sehr viel Mühle die Frage zu beantworten. 

Es kommt noch nicht mal die Antwort ob die Antworten etwas, oder gar nicht geholfen haben.. 

Antwort bewerten Vielen Dank für Deine Bewertung

In Stunden:

B2 & A2 sind belibige Zellen

=STUNDE(B2-A2)

Der Unterschied zwischen zwei Zeitangaben in der Stundeneinheit. Dieser Wert kann nicht höher als 24 sein (4).

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DragonFireHD
26.10.2016, 10:08

Du meinst 5 statt 4, oder? :D

0

Was möchtest Du wissen?