Wie kann ich in Excel innerhalb eines gewählten Bereichs eine einzige Zelle ausschließen?

...komplette Frage anzeigen

2 Antworten

Rang/Rang.gleich ist nicht gerade meine Spezialität, aber kann man denn da nicht die Matrix stückeln, zB so:


=RANG.GLEICH(Q78;{$Q78:$V78;$X78:$AV78})

Ansonsten auf eine Hilfszeile (i'wo) ausweichen mit der Beziehung

=Q78, =R78; ...=V78 und ab da eins versetzt

in Spalte W: =X78;.....=AV78 (letzteres in Spalte AU

In dieser Hilfszeile kann man dann den Rang von Q:AU auswerten

Oder aber in jeder Zelle einen Bezug zur Zelle in der gleichenm Spalte und den in Spalte W einfach löschen, ich nehme an, Rang ignoriert leere Zellen?

Antwort bewerten Vielen Dank für Deine Bewertung
FrageLars 28.03.2016, 09:37

Von Hilfszeilen habe ich noch nie etwas gehört. Aber die Lösungsvariante 1 finde ich ganz spannend. Nionmbres Lösung funktioniert ganz wunderbar, die kann ich also nehmen. Aber die verstehe ich nicht. Diesen Ansatz hier verstehe ich, den hatte ich gesucht, wusste aber nicht wie ich den Bereich ausspalten kann, ich bin nicht auf die Klammern gekommen... Prima! Da ich das ganze jetzt auch gefühlte 500 Mal auf andere Zeilen anwenden muss, werde ich wohl diese Variante nehmen, da muss ich icht ganz so viele Zeilennummern ändern. :)

3
Oubyi 28.03.2016, 17:39

@lamiam
=RANG.GLEICH(Q78;{$Q78:$V78;$X78:$AV78})

hatte ich auch sofort getestet, aber Excel 2010 akzeptiert hier kein Array.
Und ja, Rang ignoriert Leerzellen.

Interessante Idee mit der Hilfszeile.
Wenn nur eine Zelle ausgeschlossen werden soll ist wohl Ninombres Lösung sinnvoll, bei komplizierteren Anforderungen, mehr Lücken, würde das aber wohl zu komplex.

2
FrageLars 29.03.2016, 00:02
@Oubyi

Achso, wo ich das hier lese (und nicht genau, weiß, was ein Array ist, aber das ist egal) - falls das irgendwann jmd liest, der nicht so gut mit Excel umgehen kann, wie die die ganzen fleißigen Antwortengeber hier, sondern eher mein Kompetenzniveau hat: Die { durch normale Klammern ersetzten, dann funktioniert es.
=RANG.GLEICH(Q78;($Q78:$V78;$X78:$AV78))

0
Oubyi 29.03.2016, 02:54
@FrageLars

Also in meiner Testumgebung (Excel 2010) funktioniert das definitiv NICHT (Rückgabewert immer #NV).
Im Assistenten wird für den Klammerausdruck auch #WERT! angezeigt, was ich erwartet habe.
Würde mich wirklich sehr wundern, wenn das bei Dir funktioniert.

2
Iamiam 29.03.2016, 14:30
@FrageLars

Prima!

Du solltest in dem Quotienten(%) natürlich auch den gleichen Wert (ganz analog durch Stückelung der Bereiche in /Summe($..:$..;$..:$..)) ausschließen, sonst bekommst Du eine zu hohe Summe bzw bei Summierung der % 110% oder 55 Punkte(anstatt 50).

Das hat aber auf den Rang keinen Einfluss, nur die %-Zahlen des Beispiels werden unübersichtlicher und vllt stimmen auch weiterführende Rechnungen nicht mehr..

Der ausgelassene Wert hätte Rang 3, den hat aber so der zweite Wert von links (in R), also scheint alles zu stimmen.

Im übrigen hätte Rang() das gleiche Ergebnis, und weil ich bis heute noch nicht weiß, was den Unterschied ausmacht, sagte ich "nicht gerade Spezialist"

1
Oubyi 29.03.2016, 14:45
@FrageLars

Ok, Beweis akzeptiert.
Erklären kann ich das jetzt allerdings nicht.
ICH bekomme die oben beschriebene Fehlermeldung #WERT! für den Bezug, wenn ich Deine Formel in mein Excel einfüge.

1
Iamiam 29.03.2016, 14:46
@Oubyi

@Oubyi: Du darfst Dich auch mal wundern, bei mir klappts auch(xl2010)! ;)

1
Oubyi 29.03.2016, 14:50
@Iamiam

@lamiam:

Im übrigen hätte Rang() das gleiche Ergebnis, und weil ich bis heute noch nicht weiß, was den Unterschied ausmacht...

Da gibt es keinen Unterschied. RANG wurde laut Assi nur aus Kompatibilitätsgründen zu Excel 2007 beibehalten und hat die gleiche Funktion wie RANG.GLEICH

1
FrageLars 29.03.2016, 19:10
@Oubyi

Ich erst Recht nicht, ich habe weniger Ahnung als du. Dann richte ich meinem Excel einen großen Dank aus, dass es sich mir Gegenüber kooperativ zeigt. Und euch auch für eure Mühen!

Für alle, die sich genauso wie du wundern müssen, funktioniert Ninombres Weg ja aber genauso gut. :)

2

Etwas in dieser Richtung:

=WENN(RANG.GLEICH(Q78;$Q78:$AV78;0)<=RANG.GLEICH($W78;$Q78:$AV78;0);RANG.GLEICH(Q78;$Q78:$AV78;0);RANG.GLEICH(Q78;$Q78:$AV78;0)-1)

Das darf allerdings dann nicht in Spalte W stehen.

Antwort bewerten Vielen Dank für Deine Bewertung
FrageLars 27.03.2016, 22:50

Vielen lieben Dank! Das war eine große Hilfe! Langsam sollte ich in Erwägung ziehen dich und einige andere in die Danksagung meiner Arbeit mit aufzunehmen.

0
FrageLars 27.03.2016, 23:02

Oh je, da mache ich schon wieder etwas falsch. Ich habe die Formel leider überhaupt nicht verstanden, sondern nur gesehen, dasss es funktioniert, aber der Übertrag klappt jetzt nicht:

In meiner Zeile 78 klappt alles wunderbar, jetzt muss ich das aber auf weitere Zeilen übertragen. In Zeile 82 muss ich dann ja nur jede 78 durch eine 82 ersetzten, oder nicht? Dann bekomme ich aber keine Ränge, sondern nur ausschließlich den Wert 0. Ich finde bei mir keinen Fehler, aber das haut nicht hin. Was beachte ich jetzt nicht?

=WENN(RANG.GLEICH(Q82;$Q82:$AV82;0)<=RANG.GLEICH($W82;$Q82:$AV82;0);RANG.GLEICH(Q82;$Q82:$AV82;0);RANG.GLEICH(Q82;$Q82:$AV82;0)-1)

0
Iamiam 28.03.2016, 00:20
@FrageLars

kann heute leider nicht mehr groß einsteigen, aber mir scheint, dass in Zeile 82 die Bedingungen so sind, dass ein Extrem der Rangordnung auftritt.

1
FrageLars 28.03.2016, 09:28
@Iamiam

Ich nehme alles zurück. Entschuldigung. Es war zu spät und zu viel Excel für einen Tag. Ich bin in der Zeile verrutscht. Man sollte nicht die Zellen auf eine Rangordnung untersuchen, in die man die Ergebnisse ebendieser Untersuchung rein schreibt....

2
Ninombre 28.03.2016, 10:08
@FrageLars

Die $ Fixierungen sind nur an den Spalten, beim Kopieren bzw. Runterziehen der Formel sollten sich die Zeilenwerte alle passend ändern.

2

Was möchtest Du wissen?