Wie kann ich in Excel eine Zeile mit Textinhalt mit mehreren Spalten vergleichen?

... komplette Frage anzeigen

3 Antworten

Wahrscheinlich ist es sinnvoll, zunächst die Fülle an Informationen aus Spalte A in verschiedene Spalten zu trennen (Grundsatz: nur eine Information pro Zelle). Das kannst du über Daten, Text in Spalten tun.

Danach kannst du mit Sverweis, Index/Vergleich oder Zählenwenn das Vorkommen überprüfen.

Antwort bewerten Vielen Dank für Deine Bewertung

Mir fällt nur eine Lösung mit Hilfskonstrukt ein und die Suche mit *kann auch für falsche Treffer sorgen, denn die Suche nach *John Doe* findet auch erfolgreich einen John Doener

In zwei Spalten (bspw. E und F) folgende Formel, die liefern bei Treffern die Zeile des Treffers:

=WENN(B1<>"";ZEILE(INDEX(A$1:A$100;VERGLEICH("*"&B1&"*";A$1:A$100;0)));"")
=WENN(C1<>"";ZEILE(INDEX(A$1:A$100;VERGLEICH("*"&C1&"*";A$1:A$100;0)));"")

Damit werden dann die Xe in die entsprechende Zeile gesetzt: Die Formel kann in in Spalte D

=WENN(ODER(ZÄHLENWENN(E:E;ZEILE(F1))>0;ZÄHLENWENN(F:F;ZEILE(D1))>0);"X";"")
Antwort bewerten Vielen Dank für Deine Bewertung

in C1:

=wenn(nicht(istfehler(suchen(B1;A1;1)));"X";"-")

und runterziehen.

Halt, da ist die Info aus C1 noch nicht drin, also nochmal:

in D1:

Wenn(oder(nicht(istfehler(suchen(B1;A1;1)));nicht(istfehler(suchen(B1;A1;1))));"X";"-")

das unterscheidet allerdings nicht, welcher der beiden Namensmöglichkeiten (oder ob beide) zutreffen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
10.03.2016, 22:01

im zweiten Suchen natürlich nicht B1, sondern C1

oder willst Du "einer der Namen... als ganzen Spaltenbezug verstanden wissen?

0

Was möchtest Du wissen?