Wie kann ich in Excel eine Zählenwenns-Funktion oder eine Summenprodukt-Funktion mit einer Oder-Bedingung verknüpfen?

2 Antworten

direkt mit ODER in der Formel geht es nicht

=SUMMENPRODUKT(((A2:A10="sehr wichtig")+(A2:A10="eher wichtig")+(B2:B10="sehr wichtig")+(B2:B10="eher wichtig")>0)*(C2:C10="pro")*((D2:D10="sehr wichtig")+(D2:D10="eher wichtig")))

Einfacher wäre es, wenn die Angaben als Zahlen 1-4 hinterlegt wären. Dann ginge > < abzufragen.

Das Konstrukt am Anfang (A2:A10....)>0 verhindert, dass eine Zahl größer 1 rauskommt, selbst wenn sowohl in A als auch B ein Wert sehr wichtig bzw. eher wichtig hinterlegt ist (das würde sonst als 2 zählen)

DH!

So (ähnlich) hatte ich mir das auch gerade zusammengebastelt.

1
@Oubyi, UserMod Light

wobei so richtig zufrieden bin ich eigentlich noch nicht mit der Lösung. Im konkreten Fall könnte man (theoretisch) auf "* wichtig" abfragen, da "sehr wichtig" und "eher wichtig" jeweils Blank+Wichtig enthalten, aber A und B zusammenstringen und dann mit * wichtig kriege ich nicht rund.

1
@Ninombre

wenn ich mich recht erinnere, erlaubt Summenprodukt keine Textvergleiche mit *, da müsste man dann über das längliche Nicht(istfehler(suchen("Teilstring";wo1&wo2;ab wann))) gehen (hab das jetzt aber nicht ausprobiert)

0

Ich glaube, dass hier könnte funktionieren:

=WENN(((A1="sehr wichtig")+(A1="eher wichtig")+(B1="sehr wichtig")+(B1="eher wichtig"))*(C1="pro")*((D1="sehr wichtig")+(D1="eher wichtig"));"Ja";"Nein")

Damit kannst du dann eine Hilfsspalte erzeugen mit "Ja" oder "Nein", und dann die "Ja" mit einer =ZÄHLENWENN(...) zählen lassen.


Lg Tobi

Dank dir, probier ich mal.

0

Was möchtest Du wissen?