Wie kann ich in Excel eine Spalte addieren mit 2 unabhängigen Suchkriterien?

...komplette Frage anzeigen

2 Antworten

Ich sehe eingentlich keinen Grund, warum man nicht:

=SUMMEWENN(C5:C31;"Nahrung";B5:B31)+SUMMEWENN(C5:C31;"Trinken";B5:B31))

nutzen sollte. Aber alternativ kannst Du diese Formel nehmen:
=SUMMENPRODUKT(((C5:C31="Nahrung")+(C5:C31="Trinken"))*(B5:B31))

Klappt es?

Hallo,

ja es klappt. Warum ich keine doppelte Formel will? Wir haben es damals in der Schule so gelernt, dass wir unsere Formeln zusammenfassen und so übersichtlicher gestalten.

Der Rest meiner Formeln sieht super und übersichtlich aus und da wollte ich auch diese Formel einfach halten, das mit Nahrung und Trinken war lediglich ein vereinfachtes Beispiel für mein Problem ;)

0
@Naninanu13

Ok, ist Geschmackssache.
Übrigens gibt es ab Excel 2010 auch SUMMEWENNS(), womit man das lösen kann.
Eigentlich sollte es dann so klappen;
=SUMMEWENNS(B5:B31;C5:C31;"Nahrung";C5:C31;"Trinken")
aber das funktioniert bei mir komischerweise nicht. Ich kann meinen Fehler im Moment aber auch nicht finden. Anscheinend habe ich da irgendwie "ein Brett vorm Kopf".

1
@Oubyi

P.S.: Wenn das nur ein vereinfachtes Beispiel ist, dann könnte Dir auch diese Formel helfen:

=SUMMENPRODUKT((NICHT(ISTNV(VERGLEICH(C5:C31;H1:H20;0)))*(B5:B31)))

Dabei kannst Du im Bereich H1:H20 eine Liste mit Suchwörtern anlegen, also Nahrung, Trinken, usw., und es wird alles summiert, bei dem in Spalte C eines der Suchwörter aus H1:H20 steht.
Geht natürlich auch mit einer Liste direkt in der Formel:

=SUMMENPRODUKT((NICHT(ISTNV(VERGLEICH(C5:C31;{"Trinken";"Nahrung";"usw."};0)))*(B5:B31)))

2
@Oubyi

Das Problem bei deiner Formel ist, dass bei SUMMEWENNS nur die Werte addiert werden, bei denen alle Kriterien der jeweiligen Zeile erfüllt sind (quasi wie eine UND-Verknüpfung). Da in C5 nicht gleichzeitig "Nahrung" und "Trinken" (alleine) stehen kann, wird keine Zeile das Suchkriterium erfüllen. Somit ist das Ergebnis 0.

Leider funktionieren hier auch die Verwendung von UND, ODER usw. nicht als Kriterium.

0
@DeeDee07

JA!
Jetzt weiß ich, wo ich den Denkfehler hatte.Danke für Deine Hilfe.
=SUMMEWENNS(B5:B31;C5:C31;"Nahrung";D5:D31;"Trinken"
würde klappen, also zählen, wenn z.B. in C15 "Nahrung" und in D15 "Trinken" stände.
Also lässt sich das Problem des FS doch nur durch addieren oder eine meiner vorgeschlagenen Formeln lösen.

0

Schau mal in dem link nach ist gut erklärt

Für ein Haushaltsbuch mag dies sehr schön sein, jedoch ging es mir wirklich nur um diese einfache Formel, bzw. wie ich diese Formel übersichtlicher gestalten kann.

0

Was möchtest Du wissen?