Wie kann ich in Excel eine Spalte addieren mit 2 unabhängigen Suchkriterien?

2 Antworten

Ich sehe eingentlich keinen Grund, warum man nicht:

=SUMMEWENN(C5:C31;"Nahrung";B5:B31)+SUMMEWENN(C5:C31;"Trinken";B5:B31))

nutzen sollte. Aber alternativ kannst Du diese Formel nehmen:
=SUMMENPRODUKT(((C5:C31="Nahrung")+(C5:C31="Trinken"))*(B5:B31))

Klappt es?

Hallo,

ja es klappt. Warum ich keine doppelte Formel will? Wir haben es damals in der Schule so gelernt, dass wir unsere Formeln zusammenfassen und so übersichtlicher gestalten.

Der Rest meiner Formeln sieht super und übersichtlich aus und da wollte ich auch diese Formel einfach halten, das mit Nahrung und Trinken war lediglich ein vereinfachtes Beispiel für mein Problem ;)

0
@Naninanu13

Ok, ist Geschmackssache.
Übrigens gibt es ab Excel 2010 auch SUMMEWENNS(), womit man das lösen kann.
Eigentlich sollte es dann so klappen;
=SUMMEWENNS(B5:B31;C5:C31;"Nahrung";C5:C31;"Trinken")
aber das funktioniert bei mir komischerweise nicht. Ich kann meinen Fehler im Moment aber auch nicht finden. Anscheinend habe ich da irgendwie "ein Brett vorm Kopf".

1
@Oubyi

P.S.: Wenn das nur ein vereinfachtes Beispiel ist, dann könnte Dir auch diese Formel helfen:

=SUMMENPRODUKT((NICHT(ISTNV(VERGLEICH(C5:C31;H1:H20;0)))*(B5:B31)))

Dabei kannst Du im Bereich H1:H20 eine Liste mit Suchwörtern anlegen, also Nahrung, Trinken, usw., und es wird alles summiert, bei dem in Spalte C eines der Suchwörter aus H1:H20 steht.
Geht natürlich auch mit einer Liste direkt in der Formel:

=SUMMENPRODUKT((NICHT(ISTNV(VERGLEICH(C5:C31;{"Trinken";"Nahrung";"usw."};0)))*(B5:B31)))

2
@Oubyi

Das Problem bei deiner Formel ist, dass bei SUMMEWENNS nur die Werte addiert werden, bei denen alle Kriterien der jeweiligen Zeile erfüllt sind (quasi wie eine UND-Verknüpfung). Da in C5 nicht gleichzeitig "Nahrung" und "Trinken" (alleine) stehen kann, wird keine Zeile das Suchkriterium erfüllen. Somit ist das Ergebnis 0.

Leider funktionieren hier auch die Verwendung von UND, ODER usw. nicht als Kriterium.

0
@DeeDee07

JA!
Jetzt weiß ich, wo ich den Denkfehler hatte.Danke für Deine Hilfe.
=SUMMEWENNS(B5:B31;C5:C31;"Nahrung";D5:D31;"Trinken"
würde klappen, also zählen, wenn z.B. in C15 "Nahrung" und in D15 "Trinken" stände.
Also lässt sich das Problem des FS doch nur durch addieren oder eine meiner vorgeschlagenen Formeln lösen.

0

Schau mal in dem link nach ist gut erklärt

https://www.youtube.com/watch?v=bT-w3ocwiew

Für ein Haushaltsbuch mag dies sehr schön sein, jedoch ging es mir wirklich nur um diese einfache Formel, bzw. wie ich diese Formel übersichtlicher gestalten kann.

0

Wie finde ich das größte Datum in Excel pro Artikel?

Hallo, ich habe eine Artikellist mit 100 Artikeln und einer menge Daten dahinter. Was mir in dieser Tabelle fehlt, ist eine Spalte mit dem Größtem Datum aus einer anderen Tabelle, die nennt Sich Plantabelle. In dieser Plan Tabelle steht jeder der 100 Artikel mehfach mit verschiedenen Datum. Zum Beispiel Artikel A steht 12 mal in der Tabelle jeweils mit einem Datum 01.01.2017, 02.02.2017, 04.03.2017, 06.04.2017, 10.05.2017 so weiter bis Dez. Artikel B steht auch 12 mal in der Tabelle, aber alle 12 Datum nur im Januar 2017. Artikel C steht 6 mal in der Tabelle 2 mal im Feb. 2017, 2 mal Juni 2017. 1 mal im Juli und einmal im August. So gehts weiter über alle 100 Artikel - kein fester Zeitraum oder gleich Anzahl an Datensätze. Wie bekomme ich jetzt das höchste Datum pro Artikel aus der Plantabelle in meine Artikelliste hinter jedem Artikel? Dank im Voraus

...zur Frage

Wenn bei Excel in Spalte A1 bis A300 Mittwoch steht, soll in Spalte B, von B1 bis B300, neben der Zelle Mittwoch, das Wort, z.B. xy stehen. Geht das?

Sorry, habe noch nicht viel Excel erfahrung und wäre echt froh wenn mir jemand die Formel geben kann.

Wenn bei Excel in Spalte A1 bis A300 irgendwo Mittwoch steht, dann soll in Spalte B, von B1 bis B300, neben der Zelle Mittwoch, nur das Wort, z.B. xy stehen. Geht das?

...zur Frage

Formel Erklärung Excel?

Heii,Also ich mache ein Reverat über Excel und so kam ich zu der Frage wie bilden sich die Formeln also zum Beispiel:

=SUMME(B1:B8)

Also nicht nur das Beispiel sondern wie bilden sich ansich die Formeln für alle rechnungen

Es wäre nett wenn mir jemand die Formelzusammensetzung erklären könnte....

....Danke :D LG Ewii

...zur Frage

EXCEL Formel gesucht ( Kniffel programmieren)

Hallo, ich soll in Informatik das Spiel Kniffel in Excel programmieren. Ich habe soweit auch schon alles fertig. Das Einzige, dass mir noch fehlt ist eine Formel um die 5 Zufallswürfel, die mit dem Befehl ZUFALLSBEREICH 1;6 , per Klick auf ein Kästchen beim nächsten Wurf nicht mehr neu würfeln. Also ganz kurz nochmal: Ich habe 5 Würfel, die auch würfeln. Ich brauche nur noch eine Formel um bestimmte Würfel, die man anklickt bei einem erneuten Wurf nicht mehr würfeln. Zusätzlich soll es eine Sperre geben, dass mannl nur 3x würfeln kann.

Danke für eure Hilfe.

...zur Frage

Wie kann ich eine Excel Formel weiterlaufen lassen bei der sich Basiswerte ändern?

Hallo Leute,

Ich versuche eine Formel weiterzuziehen, allerdings scheint Excel die Basis der Formel nicht automatisch zu verstehen. Es ist eigentlich recht simpel: In einer immer gleich bleibenden Spalte stehen Einzelpreise für verschiedene Produkte. Auf diese soll sich jede weitere Spalte beziehen. Jede weitere Spalte ist dann ein einzelner Kunde der verschiedene Artikel in unterschiedlichen Mengen bestellt. In der untersten Zeile soll ein Gesamtpreis errechnet werden pro Kunde. Also jede Zelle mal den Preis in der jeweiligen Zeile. D5*B5+D6*B6+D7*B7 usw. Die B-Spalte sind die Preise. Beim nächsten Kunden soll es dann so weiterlaufen: E5*B5+E6*B6+E7*B7. Excel macht aber dies: E5*D5+E6*D6+E7*D7.

Ich hoffe das ist verständlich und mir kann einer helfen. Danke!

...zur Frage

Excel -wer kennt sich aus.. Formel SOLL stehen bleiben!?

Ich sitze gerade über Excel und kriege es einfach nicht hin... in zeile / spalte C4 und C5 ist jeweils eine Zahl. Ich möchte jetzt in einer anderen Spalte die Formel dazu schreiben (C4+C5) und KEINE lösung. wenn ichs eingebe, bekomme ich immer die Lösung...

Wer kann helfen? Wie gehts richtig?

...zur Frage

Was möchtest Du wissen?