Wie kann ich in Excel eine Formel anwenden, dass ich z.B. 1h + 5h = 6h zusammen rechnen kann?

... komplette Frage anzeigen

4 Antworten

  1. schreib erst mal in die Zelle 1:00 und drücke Eingabe, dann ist die Zelle schon mal auf Zeit in hh:mm-Format formatiert.
  2. gib entweder neu ein oder ergänze den Eintrag zu ="1:00"+"5:00"
  3. Eingabe drücken, fertig. es steht jetzt 6:00 da


Das ganze geht auch als "1:00:05" oder sogar gemischt: "02.04.2016 19:10:05"
Nur werden bei der Darstellung dann die Sekunden unterdrückt (aber gerechnet!), was Du per Zellformat aber ändern kannst. (zB "TTT, T.M.JJ h:mm:ss" liefert Sa, 2.4.16 19:36:28)
In Formeln musst Du den Zeitstring also immer zwischen Gänsefüßchen setzen und so schreiben, dass xl ein Zeitformat erkennen kann. (war früher wesentlich umständlicher!)

PS: in xl ist 1h = 1/24 Tag, der ist nämlich die Einheit =1 !

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
02.04.2016, 22:45

lese grad erst Deinen Kommentar zu DaMenzel. Wenn Du es unbedingt so haben willst, dann die Formel:

=WECHSELN(Zelle1;"h";"")+WECHSELN(Zelle2;"h";"")&"h"

Das Wechseln liefert eine Textziffer ohne h, durch das + wird diese als Zahl gerechnet (jede andere mathematische Operation bewirkt das auch, also *1, +0, /1, ^1 merkwürdigerweise nicht, aber ^-1 schon(??!), =SIN(WECHSELN(Zelle;"h";"")) ginge auch(aber sinnlos)

Hast Du ein Leerzeichen dazwischen, dann einfach
=WECHSELN(Zelle1;" h";"") (also LZ+h zusammen auswechseln,

Hast Du nur gelegentlich ein Leerzeichen dazwischen, dann
=WECHSELN(WECHSELN(Zelle1;" h";"");" ";"") [Wechseln liefert keinen Fehler, wenn ein Zeichen nicht gefunden wird.]


Es ist aber nicht sinnvoll, so zu rechnen, alles ist in allen gängigen Tabellenkalkulationen auf 1 = 1 Tag ausgerichtet, Anderes erfordert Zusatzaufwand.

Solltest Du schon eine größere Zahl von Zellen mit h haben, dann kannst Du sie mit obigem
=WECHSELN(Zelle1;"h";"")/24 zur Zeit im Zeitformat umwandeln, solltest aber anschließend ein Zeitformat von einer anderen Zelle auf diese Zelle mit dem Format-Pinsel übertragen.

0

Also ich bin jetzt mal genau davon ausgegangen wie oben beschrieben, dass du es wirklich ausschreiben willst:

{=SUMME(ZAHLENWERT(LINKS(B15:D15;LÄNGE(B15:D15)-1)))&"h"}

Nicht vergessen. Das ist eine Matrixformel, also Strg+SHIFT+Enter - Tastenkombi.

Das kann man alles noch weiter anpassen wenn du mehr von der Formel verlangen willst. Sag einfach bescheid!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ghanasoccer
01.04.2016, 16:51

Du hast angesprochen dass du vielleicht auch nur h dabei hast. und h als 1h gilt, somit bräuchtest du dann diese Formel (wieder Matrix):

{=SUMME(ZAHLENWERT(LINKS(WENN(B15:D15="h";"1h";B15:D15);WENN((LÄNGE(B15:D15)-1)=0;1;(LÄNGE(B15:D15)-1)))
))&"h"}

0

A1 = Stundenzahl1 "h"

B1 = Stundenzahl2 "h"

C1 = A1 + B1 "h"

Meinst Du das so? Also geht es Dir darum nur die Zahlen eintippen zu müssen, ohne dass Du extra ein "h" dahinter machen musst? Rechtsklick auf die Zellen, Zelleneigenschaften, Textformatierung, Benutzerdefiniert -> ins Feld eingeben # "h" ->speichern bzw. anwenden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von viviiilain
01.04.2016, 12:12

Ich glaube ich meine es anders. Also ich schreibe in die erste Zeile 1h und in die zweite Zeile 5h und ich möchte dann in der Summe, dass 6h rauskommt. Also , dass die Zahlen berechnet werden und das "h" eigentlich nicht beachtet wird, sondern nur übertragen wird.

0

so ganz einfach ist die Zeitrechnung in Excel nicht. Beachte hier 2 Faktoren.

1. die Formatierung der Zellen

Mache dies wie Schritt 1 - 3 im Bild. 

2. die Eingabe der Werte

Damit Excel weiss, dass Du mit Std. (und Min. etc.) rechnen willst, musst Du die Werte mit Doppelpunkt eingeben. Z.B. 

3 Std. = Eingabe 3:00:00 

wobei die ersten 00 für Min. und die Zweiten für Sek. stehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ghanasoccer
01.04.2016, 16:49

auch wenn es wahrscheinlich ist dass bei ihm h für Stunde steht, wissen wir das nich.

Also kann man nur davon ausgehen was er wirklich wortwörtlich geschrieben hat.

0

Was möchtest Du wissen?