Wie kann ich Excel vorgeben, in ca. 100 zählenwenn Formeln gleichzeitig den Suchbereich zu ändern?

...komplette Frage anzeigen

3 Antworten

es gibt die funktion "ersetzen" - markier die betroffene Zelle schreib die alte Zeile und die neue Zeile in die ersetzen formel.

geht natürlich nur wenn die änderung für alle zeilen die selbe ist.

die bessere Lösung ist, wenn du in Zukunft mit der INDIREKT Funktion deinen Suchplan dynamisch machst, z.B.:

=ZÄHLENWENN(INDIREKT(Zelle);Suchkriterium)

(Zelle) verweist auf eine beliebige Zelle, beispielhaft einmal A1

in A1 steht der Suchbereich, der dann nur eimal wöchentlich geändert werden muss und zwar ohne Anführungszeichen

z.B. B2:X999

Unter Umständen kannst du auch diesen Eintrag durch eine weitere Formel bilden, wenn es dafür mathematisch abbildbare Kriterien gibt.

Oubyi 16.12.2010, 16:28

DH! So müsste es klappen. Oder?

0
augsburgchris 17.12.2010, 08:29
@Oubyi

Nein leider klappt es so nicht da die Formel INDIREKT leider immer eine offene Quelldatei erfordert. D.h. Jeder User müsste die Quelldatei erst auf dem Server öffen. Leider bleibt dir hier nur VBA oder die bereits erwähnte Ersetzen-Version.

1
Sorbas48 17.12.2010, 10:22
@augsburgchris

das funktioniert sehr wohl und auch am Server (ich mach das mit anderen Funktionen auch so). Wesentlich ist nur, dass die Zelle auf die mit "INDIREKT" verwiesen ist in der gleichen Datei ist, wie die ZÄHLENWENN Formeln.

Der wesentliche Unterschied ist lediglich, dass die "direkten Bezüge" der Formeln in die indirekt angesprochene Zelle ausgelagert werden, nur dort anzupassen sind und nicht Zeile für Zeile edidiert werden müssen.

0
augsburgchris 17.12.2010, 12:36
@Sorbas48

und genau davon bin ich auf Grund der Aussage: "Der Suchbereich befindet sich in einem anderen Excel Dokument, dem Dienstplan, auf dem Server." nicht ausgegangen.

Der Bereich auf den verwiesen wird liegt also in einer anderen Datei. Ist diese Datei geschlossen kommt man hier mit INDIREKT nicht weiter, sobald die Datei neu durchgerechnet wird.

0
Sorbas48 17.12.2010, 13:38
@augsburgchris

aber sicher doch:

Beispiel:

In Zelle A1 steht: ='\dsrv\verzeichnis[datei.xls]Tabellenblatt'!$C$100:$H$200

die Formel lautet:

=ZÄHLENWENN(INDIREKT(A1);Suchkriterium)

das bedeutet: die Funktion nimmt sich den Zellenbezug nicht wie früher direkt aus der Formel sondern aus der Zelle A1 und greift damit auf den Server zu.

Natürlich könnte man auch das Suchkriterium indirekt gestalten.

Es kann natürlich auch der Inhalt der Zelle A1 irgend wo am Server liegen. Dann steht eben in A1 ='\dsrv\verzeichnis[datei.xls]Tabellenblatt'!Zelle

Wenn der Anwender die Datei öffnet holt sich EXCEL zuerst den Bezug (füllt A1 mit dem richtigen Wert) und die Sache läuft ganz normal weiter.

0
Sorbas48 17.12.2010, 13:45
@Sorbas48

ergänzender Hinweis:

Ich adressiere Anwendungen, die auf anderen Rechnern laufen sollen ganz bewußt indirekt und verwende bei umfangreicheren Anwendungen regelrechte Datenübergabeblätter (in der Datei der Anwendung). Das hat den Vorteil, dass ich auf meinem Rechner die Programme so testen kann als wäre ich am Zielsystem und muss mich nicht ständig mit dem relativen Bezugssystem von EXCEL abmühen.

0
smile2k 17.12.2010, 11:38

Es klappt genau wie Sorbas gesagt hat und ich sage vielen Dank!! Kann mir vielleicht noch jemand ein wenig gute Excel Lektüre empfehlen?

Greetz

0

Was möchtest Du wissen?