Wie kann ich einen Wert in Excel, der in einer Zelle steht, von einer anderen abziehen, wenn im vorherigen Feld ein bestimmter Name steht?

...komplette Frage anzeigen

3 Antworten

Angenommen, die Gesamtstückzahl steht in E1 und der Name Meier steht in D2.
Dann macht es imho am meisten Sinn in E2 diese Formel zu schreiben:
=SUMMEWENN($A$1:$A$1000;D2;$B$1:$B$1000)
Dann hast Du die Stückzahl, die Meier bekommen hast unter der Gesamtstückzahl stehen und kannst sie (und ggf. die der darunter noch stehenden Mitarbeiter) davon abziehen.
Natürlich kannst Du es auch so machen, wie von Dir beschrieben, dann mit der Formel:
=$E$1-SUMMEWENN($A$1:$A$1000;D2;$B$1:$B$1000)

Hilft Dir das?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von species1982
11.09.2016, 23:02

Mhh, ich blick das noch nicht so richtig.

Ich hab hier mal ein Beispiel erstellt:

http://fs5.directupload.net/images/160911/tsu3spm8.jpg

Als Beispiel hier Meier, bei ihm sollen 20, 7 und 19 Stück von den 1000 abgezogen werden, aber nur bei ihm. Das gleiche dann bei den anderen Namen und bei ihren Stückzahlen. Die Formel kann ruhig ausserhalb eines A4-Blattes stehen, da nur Spalte A bis C später zum arcivieren ausgedruckt wird.

0
Kommentar von species1982
11.09.2016, 23:29

Habs nochmal genau angeschaut. Dies scheint es zu sein, DANKE.

Ich probier morgen nochmal weiter, heute bin ich zu müde.

0
Kommentar von Oubyi
11.12.2016, 17:46

Danke fürs

0

Z. B. Zelle C30:

=Gesamtstückzahl-SUMMEWENN(A$1:A30;A30;B$1:B30)

Diese Formel auf den gesamtenn Bereich mit Namen und Stückzahlen erweitern.

Für Gesamtstückzahl kannst du natürlich direkt die Zahl eingeben, du kannst die Zahl aber auch in eine eigene Zelle schreiben und dieser Zelle den Namen "Gesamtstückzahl" zuweisen. (Dazu einfach auf die Zellbezeichnung, z. B. D1, doppelklicken und durch "Gesamtstückzahl" (ohne die Anführungszeichen) ersetzen.

Außerdem nimmt die Formel an, dass die Namen und Stückzahlen in Zeile 1 beginnen. Falls sie in Zeile 3 beginnen:

=Gesamtstückzahl-SUMMEWENN(A$3:A30;A30;B$3:B30)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von species1982
11.09.2016, 23:22

So in etwa scheint es zu funktionieren, nur in einem neuen Monat steht halt nicht "Meier" ganz oben sondern z.b. "Müller". Da rechnet er wieder falsch.

0

Mach unten ne Summe und lass die von der Gesamtzahl abziehen, die daneben steht.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von species1982
11.09.2016, 23:05

Danke, aber es soll ja unterschieden werden zw. den verschiedenen Mitarbeitern.

0

Was möchtest Du wissen?