Wie kann ich eine "Wenn Zelle X oder Y oder Z enthält, dann.."-Formel erstellen?

...komplette Frage anzeigen

2 Antworten

Bei zwei Werten kann man noch mit ODER arbeiten. Wenn es mehrere Suchwerte sind, könnte man über eine Matrixformel nachdenken. 

Ich überlege mir mal was...

Suboptimierer 24.11.2016, 14:39

Deine Formel funktioniert bei mir irgendwie nicht. Diese habe ich im ersten Schritt etwas anders zum Laufen gebraucht:

=WENN(SUMMENPRODUKT(NICHT(ISTFEHLER(FINDEN("Test";A1:A11)))+0)>0;"Test";"nix")

Jetzt arbeite ich an einer ODER-Verknüpfung...

1
Suboptimierer 24.11.2016, 14:43
@Suboptimierer

Das wäre die ODER-Variante

=WENN(SUMMENPRODUKT(NICHT(ISTFEHLER(FINDEN("Test";A1:A11)))+NICHT(ISTFEHLER(FINDEN("Taste";A1:A11)))+0)>0;"Test oder 

Es fehlt noch die gestaffelte Variante...

2
Suboptimierer 24.11.2016, 15:11
@Suboptimierer

Puh, das hat Schweiß gekostet. Muss man erstmal drauf kommen:

=SUMMENPRODUKT(ZÄHLENWENN($A$1:$A$13;WAHL(ZEILE($1:$2);{"*Test*";"*Taste*"})))>0
1
Suboptimierer 24.11.2016, 15:25
@Suboptimierer

Oder so, wenn du die Suchwörter in einem Zellbereich festlegen willst:

=SUMMENPRODUKT(ZÄHLENWENN($A$1:$A$13;"*"&WAHL(ZEILE($1:$2);B1:B2)&"*"))

Suchwörter in B1:B2

3
iMPerFekTioN 24.11.2016, 15:28
@Suboptimierer

DH¹⁰⁰⁰⁰⁰!!!

Krass :) Sehr schön gelöst!

Willst du die Formeln noch erläutern? :p *grins*

1
Suboptimierer 24.11.2016, 15:34
@iMPerFekTioN

Jede einzelne oder nur die letzte? Ich schreib mal nur was zur letzten, da sie quasi das Endresultat ist.

WAHL wählt aus einer Liste von Suchwörtern immer das nächste aus. Diese werden mit * umschlossen, damit sie auch innerhalb der Zellen von ZÄHLENWENN gefunden werden. SUMMENPRODUKT summiert alle gezählten Vorkommnisse (und vermeidet die Eingabe als Matrixformel).

Das muss noch auf > 0 verglichen werden, wenn man wissen will, ob ein Suchwort gefunden wurde und mit WENN umschlossen werden, wenn man in Abhängigkeit vom Ergebnis Text ausgeben will.

2
Funfroc 24.11.2016, 17:22
@iMPerFekTioN

sehr stark gelöst.

Hinweis für den Fragesteller: das hat definitiv eine hilfreichste verdient, aber sowas von.

1

Geniale Lösung von Suboptimierer!

Was möchtest Du wissen?