Wie kann ich eine Spalte in Excel auf einen Formfehler überprüfen lassen?

...komplette Frage anzeigen Hier ein Ausschnitt der Tabelle - (Computer, Excel, Programmierung)

2 Antworten

Die Gültigkeit eines Datums kannst du mit ISTZAHL(DATWERT(<Zelle>)) überprüfen und den Gültigkeitsbereich mit <>-Abfragen eingrenzen. Für die Zeit heißt die Funktion ZEITWERT, größer 12 kannst du direkt abfragen. =<Zelle> > 12

Du kannst die Zellen schon während der Eingabe überprüfen:

Daten → Datenüberprüfung

oder mit bedingter Formatierung kennzeichnen.

Start → Bedingte Formatierung

Du kannst aber auch einfach hinten eine Spalte einfügen, in der du die Angaben auf Gültigkeit überprüfst, wenn du auf Formatierung und Überprüfung während der Eingabe verzichten möchtest.

Antwort bewerten Vielen Dank für Deine Bewertung
3x4lt 21.12.2015, 11:20

Dankeschön! Hab alles über die Datenüberprüfung gemacht.

Nochmals vielen Dank! :)

2
Iamiam 21.12.2015, 12:51
@Suboptimierer

@ Subopt: es reicht =istzahl(<Zelle>), denn wenn es ein ungültiges Datum darstellt, dann ist es wegen der zwei Punkte ein Text. (gilt ja auch für 13.Monat.) (an die Gültigkeit hätt ich wieder mal nicht gedacht!)

0
Suboptimierer 21.12.2015, 12:55
@Iamiam

In meinem Test reichte ISTZAHL nicht. Beim Einfügen wird aus der Zahl 121.131.995. Die Punkte werden also als Tausendertrennzeichen erkannt und korrigiert.

Wenn in der Zelle aber schon dieser Wert steht, dann muss es sich um Text handeln (oder das Zahlenformat ist sehr merkwürdig). Das ist richtig.

0

Zusatzinfo (Suboptimierer gab ja schon Hinweise):

Welches Format einer Zelle zugeordnet ist kann man mit
=ZELLE("Format";A1)
abfragen (XL2007).

Steht in A1 "05.04.2015" ist das Format D1
steht in A1 "10:13:05" ist das Format U3
Wird als Format "S" angezeigt, ist es weder Datum noch Zeit.

Beispiel für Zeitabfrage:
=WENN(ZELLE("Format";A1)="U3";"ok";"Fehler")

Der Monat wird mit
=MONAT(A1)
abgefragt. Ist es kein gültiger Monat (>13) erscheint "'#WERT!".

Gruß aus Berlin

Antwort bewerten Vielen Dank für Deine Bewertung
Iamiam 21.12.2015, 12:55

habs jetzt zwar nicht ausprobiert, aber das eingestellte Zellformat sagt doch üblicherweise nichts über die Korrektheit des tatsächlichen Eintrags aus?

0
Britzcontrol 21.12.2015, 14:46
@Iamiam

durch Excels automatische Formatierung schon.
Bei Eingabe z.B. eines Datums in eine Zelle, in der vorher eine Uhrzeit stand, ändert sich automatisch das Zellenformat.
Der FS kann also prüfen, ob die Eingabe durch den Anwender (auf Grund der automatischen Formatierung) den Vorgaben entspricht.

0

Was möchtest Du wissen?