Wie kann ich eine Exceltabelle nach 3 Kriterien sortieren, z.B. falls jemand in A1 und A2 und A3 positive Zahlen hat, dann ist er auf Platz 1?

... komplette Frage anzeigen

3 Antworten

Allgemein kannst du die Bedingungen mit UND verknüpfen:

=UND(A1>0;A2>0;A3>0)

Ergibt WAHR, wenn alle drei Zellen positiv sind, sonst FALSCH.

In Formeln kannst du dich häufig auch eines Tricks bedienen:

=(A1>0)*(A2>0)*(A3>0)

Es kommt 1 (entspricht WAHR) heraus, wenn alle Bedingungen erfüllt sind, sonst 0 (entspricht FALSCH).

Eine Abkürzung wäre hier:

=MIN(A1:A3)>0
Antwort bewerten Vielen Dank für Deine Bewertung

Wenn man einfach nur die Summe über die drei Spalten nimmt, wird eine
negative Zahl nicht speziell bewertet, also 9 / -1 / 9 wäre höher als 5 /
5 / 5 - das ist aber offensichtlich so nicht gewünscht.

Die genaue Logik musst daher noch erläutern:

Wie ist die Reihenfolge, wenn mehrere Ergebnisse vorliegen, die nur positive Zahlen haben? Dann das höchste Gesamtergebnis (also Summe der drei Spalten)?

Was ist mit den Kandidaten die eine (bzw. 2/3) negative Zahlen haben? Wie ist die Reihenfolge dort angesetzt?

Wenn nur Ergebnisse mit positiven Zahlen weiter verglichen werden sollen, kannst Du in eine Hilfsspalte arbeiten. Annahme A / B /  C enthalten die Werte, dann wäre D als HIlfsspalte:
=WENN(ZÄHLENWENN(A2:C2;"<0")=0;SUMME(A2:C2);"")

und Spalte E
=WENN(ISTZAHL(D3);RANG(SUMME(A3:C3);D$2:D$6;0);"")

Die Kandidaten mit einem oder mehreren negativen Werten sind nach dieser Logik aber automatisch raus aus dem Ranking. Für andere Lösungen bräuchte man nähere Vorgaben von Dir

Antwort bewerten Vielen Dank für Deine Bewertung

Erstelle in einem jeweils vierten Feld A4 eine Summe aus A1, A2 und A3 und Sortiere die Tabelle nach dieser. Das entsprechende vierte Feld kannst du auch unsichtbar machen, da die Zahlen wahrscheinlich weniger aussagekraft haben.

Damit hättest du jedoch nur ein Ranking nach dem besten Gesamtergebnis.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?