Wie kann ich eine Excel Tabelle kopieren in der =WENN(B1>0;A1;““) steht, ohne die Zeilen zu kopieren in denen;““) nichts steht?

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Hey,

was du auch machen kannst ist sortieren.

Sortiere eine Spalte z.B. ab oder aufsteigend, dadurch werden dir alle Leerzellen nacheinander angezeigt und du kannst sie bequem löschen.

Eine andere Möglichkeit wäre (wenn du sonst keine doppelten Werte in der Tabelle hast) doppelte Einträge löschen, so gibt es nur noch eine leerzelle, die du manuell löschen kannst.

Was Suboptimierer geschrieben hat, kenne ich so nicht und habe ich gerade auf die Schnelle auch nicht gefunden.

Es gibt noch eine Idee, die ich gerade probiert habe:

  • Markiere deinen Bereich mit den Leerzellen.
  • Drücke "strg + f" (das Fenster Suchen und Ersetzen sollte sich öffnen)
  • unter dem Punkt Ersetzen gehst du einfach direkt auf "Alle suchen"
  • Markiere alle gefundenen Einträge in dem unteren Fenster
  • Klicke in eine Excel Mappe und drücke "strg + -" das löscht die Zellen

WICHTIG!!!! Sichere dir vorher deine Tabelle, falls etwas schief gehen sollte ;-)

Viel Erfolg.

Das hat funktioniert mit strg f, markieren und dann Zellen löschen, Danke, ich habe auch das von Suboptimierer probiert aber leider wollte das nicht funktionieren, ich habe das Häkchen gesetzt aber nichts passierte, trotzdem danke für die Antwort

1
@Marceloblau01

DH!

Nur eine klitzekleine Ergänzung.

Mit STRG & H kommt man direkt zu Suchen/ Ersetzen, ohne über Finden (STRG&F) gehen zu müssen. Spart ca. 1/2 Sekunde 🙂

0

Wenn du als Einfügeaktion "Inhalte Einfügen..." wählst, kannst du einen Haken bei "Leerzellen überspringen" setzen.

Hab ich auch gedacht, aber merkwürdigerweise funkt das bei mir nicht (xl2010 auf Windows7)

0

Willst du in der neuen Datei die Formel oder den Wert haben? Leere überspringen kann hier nicht funktionieren, da die Zellen ja nicht leer sind sondern eine Formel enthalten die das Ergebnis eines Leerstrings ausgibt. Leerstring <> leere Zelle

Excel soll Automatisch Text ausfüllen wenn eine Zahl angegeben wird?

Hallo

Ich bekomme eine Liste mit Zahlen und muss diese dann in Excel eintragen, bzw. Raussuchen welches Wort zu welcher Zahl passt und dann das noch eingeben. Excel soll dann anhand der von mir angegeben Zahl in einerm anderen einen Passenden Text hinsetzten. Wenn aber nichts da steht soll da nicht WERT oder NAME oder so stehen sondern es soll leer bleiben.

Beispiel Ich bekomme die Liste Name | Datum | Objekt

Das Objekt ist nur eine Zahl

Hans | 1.6.16 | 5

Excel soll mir dann neben der Zahl das Objekt in Worte fassen

Hans | 1.6.16 | 5 | Garten

Wenn dann aber bei der Objekt Zahl noch kein Wert drin steht soll da auch nichts stehen. Auch kein Fehler.

Zudem möchte ich die Formel eingeben können und einmal nach unten ziehen und nicht jedesmal alles eingeben müssen.

Ich habe alle Werte in der Selben Arbeitsmappe in Tabelle 2 eingegeben. In Tabelle 1 Arbeite ich.

Tabelle 2 sieht in etwa so aus

1 | Wohnung 2 | Haus 3 | Platz 4 | Abstellraum 5 | Garten

Habe dann versucht das ganze mit sverweis zu lösen.

=SVERWEIS(B1;Tabelle2!A1:B16;2)

Sprich Wenn in B1 eine Zahl steht; Aus Tabelle 2 A1-B16; in der zweiten spalte dann soll er das Wort dahinter nehmen.

Klappt soweit ziemlich gut, nur Probelem sind trotzdem da.

  1. Wenn noch Kein Wert (Zahl) in Tabelle 1 steht dann steht da #NV Wie bekomme ich das Weg?

  2. Ich kann die Formel nicht runter ziehen sonst werden alle Werte geändert

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A2:B16;3) =SVERWEIS(B3;Tabelle2!A3:B16;4)

jedoch sollte es beim runterziehen der Formel so aussehen:

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A1:B16;2) =SVERWEIS(B3;Tabelle2!A1:B16;2)

Weil die Matrix (A1:B16) bleibt ja die selbe.

Bin dankbar über jeden Rat. Es muss nicht mit sverweis gelöst sein. Jedoch suchen und ersetzen ist auch keine Option, da es zum einen mehr aufwand ist und zum anderen benötige ich ja die Zahl und das dazugehörige Wort.. Geht aber auch nicht immer.

Danke euch Gruss Grischabock

...zur Frage

Was möchtest Du wissen?