Wie kann ich den Wert einer Zelle in eine Formel einfügen?

...komplette Frage anzeigen

3 Antworten

Hallo,

die Funktion die du suchst ist =INDIREKT()

Mit Indirekt, greifst du auf den INDIREKTEN Wert einer Zelle zu, d.h. wenn du in der Zelle eine Formel hast, wird das Ergebnis dieser Formel ausgewertet und nicht der Inhalt der Zelle.

"Bestimmt den Inhalt einer als Bezug in Textform angegebenen Zelle"

Liebe Grüße,

iMPerFekTioN

xXSnip3rXx 25.01.2017, 11:58

Hat Suboptimierer mir auch empfohlen ^^ jedoch egal wie ich es kombiniere kommt ein Bezug raus ... :/ ich lese mich aber mal weiter rein ... vllt habe ich etwas übersehen

Danke schonmal für die Erläuterung der INDIREKT Funktion

1
iMPerFekTioN 25.01.2017, 12:03
@xXSnip3rXx

Wenn deine Formel ausgeführt wird, was steht dann als Hyperlink in der Zelle? Kannst du mir das mal kurz schildern?=)

1
iMPerFekTioN 25.01.2017, 12:09
@iMPerFekTioN

Als kurzer Einstieg:

Wenn du in Tabelle1 in Zelle A1 folgendes stehen hast:

Tabelle2!A1:B5

Tabelle2 enthält folgende Tabelle im Bereich A1:B5

1 2
2 3
3 4
4 5
5 6

So, ...

...jetzt schreibst du in Tabelle1 eine =SVERWEIS() Funktion in die Zelle A2.

=SVERWEIS(A3;INDIREKT(A1);2;0)

Jetzt wird je nach dem welche Zahl du in Tabelle1!A3 eingibst der =SVERWEIS() korrekt ausgeführt.

Damit kannst du doch sicherlich was anfangen oder? ;)

Liebe Grüße,

1
iMPerFekTioN 25.01.2017, 12:11
@xXSnip3rXx

Super! Ist ja auch nicht verkehrt :p

Trotz allem ist es wichtig, (auch bei Fremder Hilfe und Fremden Funktionen/Formeln) die Thematik dahinter zu verstehen,

Was nützt eine Tabelle, die funktioniert, wenn man Sie nicht versteht?
Darum nochmals meine kurze Erläuterung :)

Viel Spaß weiterhin und viel Erfolg,

Liebe Grüße,

iMPerFekTioN

1
xXSnip3rXx 25.01.2017, 12:15
@iMPerFekTioN

Die INDIIREKT formel habe ich jetzt halbwegs verstanden ^^ die Große Formel oben habe ich in der "Art und Weise" verstanden und könnte bzw. habe Sie auch abgeändert ... 

Jedoch die komplette Funktionsweise (vorallem INDEX) blicke ich noch nicht ganz durch ... lese mich aber (wenn ich mal zeit habe ;D) da durch

1
iMPerFekTioN 25.01.2017, 12:27
@xXSnip3rXx

Also,

das kann ich dir eigentlich auch ganz schnell erklären :-)

So aus dem Stegreif mach ich das jetzt einfach mal aus dem Kopf:

Du weißt bestimmt was Zeilen und Spalten sind.

Dort wo sich Spalte und Zeile treffen hast du eine Zelle mit einer Positionsangabe.

Beispiel:

Spalte C und Zeile 4

Wo sich diese beiden treffen, hast du die Zelle mit der Position C19

  A         B         C         D
1                       X
2                       X
3                       X
4XXXXXXXXXO
5

Du verseht auf was ich hinaus möchte?
So, dann zur =INDEX()-Funktion:

Die Index-Funktion hat 3 Argumente:

=INDEX(A1:D5;2;3)


Matrix (A1:D5): das ist der Bereich, in dem nach einem Wert gesucht wird. [=INDEX(A1:D5;2;3)]

Zeile (2): das ist die Zeile, die durchsucht wird. Da wir hier eine 2 stehen haben [=INDEX(A1:D5;2;3)], wird natürlich die 2. Zeile der Matrix (A1:D5) genommen.

Spalte (3): das ist die Spalte, die durchsucht wird. Da wir hier eine 3 eingegeben haben [=INDEX(A1:D5;2;3)], wird die 3. Spalte der Matrix (A1:D5) genommen!

So, nehmen wir die Tabelle von oben nochmal:
  A         B         C         D
1                      
2                      
3                      
4                      20
5

In der Zelle C4 steht nun die Zahl "20".

Wenn du jetzt die Funktion =INDEX(A1:D5;4;3) eingibst, erhältst du den Rückgabewert des Schnittpunktes innerhalb der Matrix A1:D5, der 4. Zeile und der 3. Spalte.

Was hier C4 wäre, als Ausgabe erhältst du dann also die 20 =)

Super oder?=)

Grüße,

iMPerFekTioN

0

Probier dich mal am INDIREKT aus.

xXSnip3rXx 25.01.2017, 11:54

Habe ich mir mal kurz durchgelesen aber egal wie ich mit der INDIREKT Formel die Zelle A2 kombiniere kommt ein Bezug raus :/

1

Danke an iMPerFekTioN für die erläuterung der INDIREKT Formel und natürlich auch wieder danke an @Suboptimierer 

Habe mich ein wenig eingelesen und die Folgende Funktion gebastet die auch Funktioniert :) 

=INDIREKT("'"&A2&"'!J7")

Mein Fehler war bei meinen ersten versuchen das ich die 

"'"& und &

vor dem A2 vergessen hatte.

MfG

Was möchtest Du wissen?